Bug 196300 - rename of cluster mirror logical volume causes dev_open while suspended
Summary: rename of cluster mirror logical volume causes dev_open while suspended
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-22 14:33 UTC by Jonathan Earl Brassow
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 18:48:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvrename output (48 bytes, text/plain)
2006-06-22 14:33 UTC, Jonathan Earl Brassow
no flags Details
clvmd output (41.59 KB, text/plain)
2006-06-22 14:35 UTC, Jonathan Earl Brassow
no flags Details

Description Jonathan Earl Brassow 2006-06-22 14:33:50 UTC
cluster mirrors were hanging when renamed.  The reason turned out to be that the
mirror constructor was called for the newly renamed volume before the destructor
was called on the original volume.  This caused two copies of the exact same
instance to be loaded in the kernel at the same time.  (The cluster mirror
logging code was not able to handle this at the time.)

Further investigation revealed the following warnings being printed from clvmd:
lvm[4498]: WARNING: dev_open(/dev/sdb) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdc) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdd) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdb) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sda) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdc) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdd) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdc) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sda) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdb) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdd) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdd) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sda) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdb) called while suspended
lvm[4498]: WARNING: dev_open(/dev/sdc) called while suspended

I am using the very latest in CVS for both dm and LVM2.  We should not be
scanning while devices are suspended.

I'm attaching traces for the lvrename command and clvmd (note: the last command
processed in the clvmd output is the lvrename)

Comment 1 Jonathan Earl Brassow 2006-06-22 14:33:50 UTC
Created attachment 131357 [details]
lvrename output

Comment 2 Jonathan Earl Brassow 2006-06-22 14:35:11 UTC
Created attachment 131358 [details]
clvmd output

Comment 4 Alasdair Kergon 2006-10-18 18:42:16 UTC
mirror renames (both single-host and clustered) are not yet supported as they
are non-trivial.

The latest code enforces this.

Do you want to leave this open as a feature request for the ability to rename
mirrors?

Comment 5 Jonathan Earl Brassow 2006-10-18 18:48:04 UTC
I think at some point we'll want to rename, but this bug can be closed, as I'm
sure we'll have to address this issue as part of that implementation.



Note You need to log in before you can comment on or make changes to this bug.