Bug 196344 - Update libnotify to 0.4.2 and fix devel requirements
Update libnotify to 0.4.2 and fix devel requirements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
: EasyFix, Reopened
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-06-22 13:33 EDT by Matthias Saou
Modified: 2013-03-13 00:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 14:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-06-22 13:33:17 EDT
Hi, while trying to rebuild the latest bmpx on Fedora Core development, it
failed because it requires libnotify >= 0.4.2 and Rawhide currently "only" has
0.4.0.

Would it be possible to update the package to 0.4.2? Thanks!
Comment 1 Matthias Saou 2006-06-26 08:00:27 EDT

*** This bug has been marked as a duplicate of 191731 ***
Comment 2 Matthias Saou 2006-07-21 04:36:39 EDT
Please update libnotify to 0.4.2 ASAP. See the patch from bug #191731 if you
want, but it's pretty straightforward.
Comment 3 Matthias Saou 2006-07-21 07:54:13 EDT
Another problem in the current package worth mentioning :

"Package 'dbus-glib-1', required by 'libnotify', not found"

From the libnotify.pc file :

Requires: gtk+-2.0 >= 2.2.2, glib-2.0 >= 2.2.2, dbus-1 >= 0.36, dbus-glib-1 >= 0.36

This would have been picked up automatically if rpm had been recent enough, but
for the time being, requirements should be manually added to the libnotify-devel
package. At least dbus-glib-devel and possibly dbus-devel (*) since gtk2-devel
is already listed and requires glib2-devel.

(*) Current dbus-glib-devel doesn't require dbus-devel, this seems like a bug
since its pkgconfig file indicates it requires it.
Comment 4 John (J5) Palmieri 2006-07-21 14:54:31 EDT
Building in rawhide now.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.