Bug 196369 - Need newer sha* hashes
Need newer sha* hashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: Reopened
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-06-22 15:42 EDT by James Antill
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.97-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 04:04:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backport patch to add sha*sum and base64 hashing/encoding (119.57 KB, patch)
2006-06-22 15:42 EDT, James Antill
no flags Details | Diff

  None (edit)
Description James Antill 2006-06-22 15:42:40 EDT
Description of problem:
 sha256sum, sha512sum etc. are present in upstream development but not in our
package.

Version-Release number of selected component (if applicable):



Additional info:

 I'm including a patch backported from upstream development (the backport was
blessed by the maintainer). It adds the new sha* commands and base64 ... and tests.
Comment 1 James Antill 2006-06-22 15:42:40 EDT
Created attachment 131378 [details]
Backport patch to add sha*sum and base64 hashing/encoding
Comment 3 Tim Waugh 2006-06-22 18:40:57 EDT
5.96-4 building.
Comment 4 Tim Waugh 2006-06-23 04:13:16 EDT
Test cases failed on s390 (but succeeded on ia64).
Comment 7 Jim Meyering 2006-06-23 09:35:14 EDT
It appears to be a bug in gcc/memcpy, since memcpy transforms the first four
bytes of a buffer from 128 to 9223372036854775808 (aka 0x8000000000000000). 
Building with -fno-builtin avoids the problem.  I'll submit a test case shortly.
Comment 8 Jim Meyering 2006-06-23 12:11:10 EDT
Update: a better-controlled experiment suggests that the test failures are due
to a bug in gcc's -O2.  When I compile sha512.c with -O1 and relink, the tests pass.
Comment 9 Jim Meyering 2006-06-23 16:24:20 EDT
FYI, the s390 gcc -O2 problem is being tracked here:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28146
Comment 11 Tim Waugh 2006-06-26 04:04:23 EDT
Thanks for working out the problem!  For the moment I've built coreutils with
-O1 on s390/s390x.

Note You need to log in before you can comment on or make changes to this bug.