Bug 196377 - "Enabling local swap partitions:" always fails
Summary: "Enabling local swap partitions:" always fails
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-22 20:10 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-11 17:08:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of failure during booting time (10.76 KB, image/png)
2006-06-22 20:11 UTC, Robert Scheck
no flags Details

Description Robert Scheck 2006-06-22 20:10:27 UTC
Description of problem:
"Enabling local swap partitions:" always fails with "swapon: /dev/cciss!c0d0p3: 
Device or resource busy" ("Fehlgeschlagen" means "failed") - sorry for the 
German screenshot. The problem is not SELinux related, I was just relabeling 
before, but this error is displayed during any startup.

Swap seems to be available normal:
$ cat /proc/swaps
Filename                                Type            Size    Used    Priority
/dev/cciss/c0d0p3                       partition       1048552 0       -1
$

$ free
             total       used       free     shared    buffers     cached
Mem:       1032956     926776     106180          0     191764     201876
-/+ buffers/cache:     533136     499820
Swap:      1048552          0    1048552
$

$ grep swap /etc/fstab
/dev/cciss/c0d0p3       swap                    swap    defaults           0 0
$

Version-Release number of selected component (if applicable):
initscripts-8.35-1

Expected results:
Would be very nice to see this fixed. Please reassign the bug to the quota 
package, if needed...

Comment 1 Robert Scheck 2006-06-22 20:11:38 UTC
Created attachment 131383 [details]
Screenshot of failure during booting time

Comment 2 Bill Nottingham 2006-06-29 04:24:31 UTC
Oh, blah. blkid returns the path with the '!' in it?

Comment 3 Bill Nottingham 2006-07-21 15:56:35 UTC
What's the output of 'blkid' on your system?

Comment 4 Robert Scheck 2006-07-21 17:14:21 UTC
Oh, didn't get comment #2 per e-mail. Here's output of blkid (UUIDs have been 
trunicated) on my system:

/dev/cciss/c0d0p1: LABEL="/boot" UUID="41e532d3cc77" SEC_TYPE="ext2" TYPE="ext3"
/dev/cciss/c0d0p2: LABEL="/" UUID="b601fb50c59a" SEC_TYPE="ext2" TYPE="ext3"
/dev/cciss/c0d0p3: TYPE="swap"
/dev/cciss!c0d0p3: TYPE="swap"
/dev/cciss!c0d0p2: LABEL="/" UUID="b601fb50c59a" SEC_TYPE="ext2" TYPE="ext3"
/dev/cciss!c0d0p1: LABEL="/boot" UUID="41e532d3cc77" SEC_TYPE="ext2" TYPE="ext3"

Comment 5 Bill Nottingham 2006-07-21 17:49:48 UTC
OK, that needs fixed in libblkid; it should not be returning paths with the '!'
in it...

Comment 6 Thomas Woerner 2006-07-24 09:02:19 UTC
No, it is no option that libblkid does not resolve partitions where the path
contains special chars. This is no option at all.

The question is: Where does these special entries come from?

Assigning back to initscripts.

Comment 7 Bill Nottingham 2006-07-24 14:07:14 UTC
? These entries are returned by blkid... it's reading the '!' path from sysfs,
and needs to be able to resolve it to the actual device.

Comment 8 Robert Scheck 2006-11-11 17:08:19 UTC
The initial problem seems to be fixed for me at least in initscripts 8.46-1
and/or e2fsprogs 1.39-7.


Note You need to log in before you can comment on or make changes to this bug.