Bug 1963782 - Kernel 5.12.5-300.fc34.x86_64 is not usable
Summary: Kernel 5.12.5-300.fc34.x86_64 is not usable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 34
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1963316 1963677 1963797 1964225 1964252 1964329 1964448 1964866 1965048 1965533 (view as bug list)
Depends On:
Blocks: 1973370
TreeView+ depends on / blocked
 
Reported: 2021-05-24 02:23 UTC by rtqate
Modified: 2021-06-22 19:25 UTC (History)
40 users (show)

Fixed In Version: kernel-5.12.7-300.fc34 kernel-5.12.7-200.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1973370 (view as bug list)
Environment:
Last Closed: 2021-05-28 01:00:31 UTC
Type: Bug


Attachments (Terms of Use)
Kernel log (99.57 KB, text/plain)
2021-05-24 02:23 UTC, rtqate
no flags Details

Description rtqate 2021-05-24 02:23:15 UTC
Created attachment 1786232 [details]
Kernel log

Created attachment 1786232 [details]
Kernel log

1. Please describe the problem:
# Edited:
# One or more of the following happens:
  # The login screen freezes - not possible to type anything, or, if the p/w is entered, the enter key is non-responsive
  # If the login is successful, many apps do not work:
    # E.g., Firefox, Software center, etc, do not start (the loading process is seen, though, but the apps never appear)
    # I tried to do "sudo dnf update" - the terminal accepted the command, but never came back with the response (no text produced on the screen, just the blinking cursor)... 


2. What is the Version-Release number of the kernel:
5.12.5-300.fc34.x86_64 


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
No


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
# Boot into kernel 5.12.5-300.fc34.x86_64 
# Attempt to log in:
   # If login is successful, try to open some of the apps (e.g,  Firefox or Software manager). Actual result - the apps never load.
   # Two times, freeze during login was seen


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Not sure about Rawhide, as I'm on the stable version.

6. Are you running any modules that not shipped with directly Fedora's kernel?:
Not sure about any such modules, but most likely not.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.
*.txt file attached, collected with -b flag.

Comment 1 H.Janssen 2021-05-24 13:48:10 UTC
Similar problem here. System boots into lightdm's greeter and freezes before loading the wallpaper.  

Info I could obtain (not reportable according to abrt)

May 24 15:27:32 lap2.home kernel: list_add double add: new=ffff8a3009891320, prev=ffff8a3009891320, next=ffff8a30098a5b38.
May 24 15:27:32 lap2.home kernel: kernel BUG at lib/list_debug.c:29!

And earlier: list_del corruption. next->prev should be ffff8fa28112c620, but was ffff8fa388667d60

Comment 2 Justin M. Forbes 2021-05-24 22:29:23 UTC
*** Bug 1963797 has been marked as a duplicate of this bug. ***

Comment 3 Justin M. Forbes 2021-05-24 22:30:03 UTC
*** Bug 1963677 has been marked as a duplicate of this bug. ***

Comment 4 Justin M. Forbes 2021-05-25 01:37:07 UTC
I believe it is likely that 5.12.7 will have a fix for your issue. If you wouldn't mind giving my test build of rc1 a boot and seeing if it fixes things, I would appreciate it.  Unfortunately, it is a scratch build, so not secure boot signed. It is listed as 5.12.6-301.fc34 so that it should update over 5.12.6-300.fc34, and still get replaced by 5.12.7-300.fc34.

https://koji.fedoraproject.org/koji/taskinfo?taskID=68650184

Not sure how long until it finishes as scratch builds do not get the same priority that official builds do.

Comment 5 rtqate 2021-05-25 04:30:19 UTC
Thanks for looking into this issue! I tried installing the scratch build from this koji link. It still appears to have the same problems, unfortunately.

Comment 6 rtqate 2021-05-25 04:32:32 UTC
On my system, when I do rpm -qa kernel, it is shown as 5.12.6-301.fc35.x86_64 (not fc34). Same on Grub. Hope this helps!

Comment 7 H.Janssen 2021-05-25 06:56:53 UTC
My issue seems to be fixed with this version, lightdm starts and everything seems to be normal.
uname -r 
5.12.6-301.fc35.x86_64

But I've also found lateron item 1963316, the author explicitely mentioned unable to login into lightdm which matches more my problem. 



For your info: I also tried 5.13.0-0.rc2.20210521git79a106fc6585.22.fc35 which passed the lightdm login but froze during application load....

Linux version 5.13.0-0.rc2.20210521git79a106fc6585.22.fc35.x86_64 (mockbuild.fedoraproject.org)
.....
May 24 16:35:41 lap2.home abrt-notification[2422]: [🡕] System encountered a non-fatal error in vm_fault_gtt()
kernel BUG at mm/memory.c:2183! [i915]
I'll save the abrt info in case someone is interested. 

Thanks a lot !

Comment 8 please delete this account 2021-05-25 09:28:21 UTC
I've got a similar effect with an old hp compaq 6910p

unfortunately I can't confirm it's with 5.12.6

booting to former vmlinuz-5.11.21-300.fc34.x86_64 -> no problem

booting to runlevel 3 of vmlinuz-5.12.5-300.fc34.x86_64 or vmlinuz-5.12.6-300.fc34.x86_64 -> no problem

booting to graphical desktop of vmlinuz-5.12.5-300.fc34.x86_64 or vmlinuz-5.12.6-300.fc34.x86_64 -> freezes after 2-5 secs
- entering cryptfs password works without any trouble
- graphical desktop inc. background starts, but after a short moment e.g moving cursor -> freeze
- unfortunately no keybord or touchpad any mor, so I'm not able to switch to a console
- no problem report is created
- need to turn of power 

booting to runlevel 3 and then telinit 5 -> freeze

in contrast the 5.12.6 works on a new acer aspire 5 without any problems, as far as I noticed

I'll wait for 5.12.7 and will provide a feedback, if 5.12.7 solves the problem

if someone needs further information, feel free to contact me

Comment 9 please delete this account 2021-05-25 09:34:36 UTC
Sorry, sorry,
I mismatched the bug ids
actually I wanted to report to then more appropriate 1963316

Comment 10 Justin M. Forbes 2021-05-25 11:29:49 UTC
*** Bug 1964252 has been marked as a duplicate of this bug. ***

Comment 11 Justin M. Forbes 2021-05-25 11:31:01 UTC
*** Bug 1963316 has been marked as a duplicate of this bug. ***

Comment 12 Justin M. Forbes 2021-05-25 11:31:24 UTC
*** Bug 1964225 has been marked as a duplicate of this bug. ***

Comment 13 Justin M. Forbes 2021-05-25 11:31:41 UTC
*** Bug 1964329 has been marked as a duplicate of this bug. ***

Comment 14 Justin M. Forbes 2021-05-25 11:39:31 UTC
You didn't mismatch, that bug was duped to this one. The patch that should fix that issue is https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable-rc.git/commit/?h=linux-5.12.y&id=a3f5bd1c8a738d5f650ee2dfeeede9608e9088ed

Sorry about the fc35 build, though that kernel should work fine, unless you need to build 3rd party modules.  I have started a proper fc34 scratch build at: https://koji.fedoraproject.org/koji/taskinfo?taskID=68688143 (just now, so give it a few).

Comment 15 Jiri Kastner 2021-05-25 12:08:17 UTC
tested 5.12.6-301.fc35.x86_64, works fine

Comment 16 Allen 2021-05-25 12:58:59 UTC
I have an old Dell Latitude D630 that also has a similar problem with kernel-5.12.5-300. The system boots to the GNOME login screen but clicking on anything causes a system freeze. I can ssh into the system and can see nothing wrong. I added a line into the log and then attempted to log in but that line is the last line in the log and there is nothing after.

Booting any previous kernel is fine.

Comment 17 Justin M. Forbes 2021-05-25 14:03:55 UTC
*** Bug 1964448 has been marked as a duplicate of this bug. ***

Comment 18 H.Janssen 2021-05-25 15:04:18 UTC
And tested 5.12.6-301.fc34.x86_64 on a HP6730b and it works OK, including compilation and use of virtualbox module. 

Thanks for fixing so quickly.

Comment 19 James Tabor 2021-05-25 18:03:21 UTC
See Bug https://bugzilla.redhat.com/show_bug.cgi?id=1964225

Update to the new kernel 5.12.6-200.fc33.x86_64, still having the same issue.

Everything work on the login GUI, except selecting the user and the system freezes.

Should I use a different kernel?

Comment 20 Albert Flügel 2021-05-25 20:42:55 UTC
Had installed the rawhide kernel 5.13.0-0.rc2.20210521git79a106fc6585.22.fc35.x86_64 to test.
The T500 worked for about half an hour normally, then, when switching a short video to full screen in firefox, the laptop froze. No reaction to mouse move (pointer stuck), or any keyboard input including Ctrl-Alt-Whatever. Interestingly the sound played on for 5 seconds or so.

Comment 21 Justin M. Forbes 2021-05-25 21:56:57 UTC
James, yes, the 301 build is a special build, it is actually 5.12.7-rc1. 200 and 300 are the real 5.12.6 and do not contain the fix mentioned here. 

Albert, the fix was added late in rc2, I don't think it was in that build. 5.13-rc3 and newer will have it, and the 5.12.6-301 kernels I linked above.

Comment 22 rtqate 2021-05-25 23:33:05 UTC
5.12.6-301.fc34.x86_64 is not working either, nor does 5.12.6-300... I can log in without problems (that part of the bug is fixed :) ), but I still cannot run apps (e.g., Firefox). 
 Hope this helps, thanks again!

Comment 23 John Apple II 2021-05-26 08:40:38 UTC
I'm having the issue with 5.12.6-300 as well.  I've versionlocked 5.11.21-300, which is the last version I have that worked for me - in my case logind and Networkmanager fail when I've gone and looked at them.

Failures are as follows with both of these two kernels (same errors), but on the previous kernel I get tpm soft-lockup errors on my Lenovo T590.  I haven't been able to trace the errors further than this thus far, as dmesg doesn't show anything unusual that I can see.

5.12.5-300
5.12.6-300

I'll see if I can give it a try with the above, but here are the specific errors I'm seeing with the newer kernels.  I've had to versionlock 5.11.21-300 as this is the last functioning kernel for my system.

---- LOGS below -----

systemd-logind:

-- Boot 277b827965a9461eb976398c10bee096 --
May 26 11:04:29 systemd[1]: Starting User Login Management...
May 26 11:04:29 systemd-logind[4792]: Failed to connect to system bus: Connection refused
May 26 11:04:29 systemd-logind[4792]: Failed to fully start up daemon: Connection refused
May 26 11:04:29 systemd[1]: systemd-logind.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:29 systemd[1]: systemd-logind.service: Failed with result 'exit-code'.
May 26 11:04:29 systemd[1]: Failed to start User Login Management.
May 26 11:04:29 systemd[1]: systemd-logind.service: Scheduled restart job, restart counter is at 1.
May 26 11:04:29 systemd[1]: Stopped User Login Management.
May 26 11:04:29 systemd[1]: Starting User Login Management...
May 26 11:04:29 systemd-logind[4802]: Failed to connect to system bus: Broken pipe
May 26 11:04:29 systemd-logind[4802]: Failed to fully start up daemon: Broken pipe
May 26 11:04:29 systemd[1]: systemd-logind.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:29 systemd[1]: systemd-logind.service: Failed with result 'exit-code'.
May 26 11:04:29 systemd[1]: Failed to start User Login Management.
May 26 11:04:29 systemd[1]: systemd-logind.service: Scheduled restart job, restart counter is at 2.
May 26 11:04:29 systemd[1]: Stopped User Login Management.
May 26 11:04:29 systemd[1]: Starting User Login Management...
May 26 11:04:29 systemd-logind[4806]: New seat seat0.
May 26 11:04:29 systemd-logind[4806]: Watching system buttons on /dev/input/event2 (Power Button)
May 26 11:04:29 systemd-logind[4806]: Watching system buttons on /dev/input/event1 (Lid Switch)
May 26 11:04:29 systemd-logind[4806]: Watching system buttons on /dev/input/event0 (Sleep Button)
May 26 11:04:29 systemd-logind[4806]: Watching system buttons on /dev/input/event12 (Metadot - Das Keyboard Das Keyboard System Control)
May 26 11:04:29 systemd-logind[4806]: Watching system buttons on /dev/input/event10 (Logitech G502 HERO Gaming Mouse Keyboard)
May 26 11:04:29 systemd-logind[4806]: Watching system buttons on /dev/input/event3 (AT Translated Set 2 keyboard)
May 26 11:04:29 systemd-logind[4806]: Watching system buttons on /dev/input/event14 (ThinkPad Extra Buttons)
May 26 11:04:30 systemd[1]: Dependency failed for User Login Management.
May 26 11:04:30 systemd[1]: systemd-logind.service: Job systemd-logind.service/start failed with result 'dependency'.
May 26 11:05:23 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:30 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:31 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:31 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:33 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:38 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:39 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:40 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:40 systemd-logind[4806]: Failed to start autovt: Transport endpoint is not connected
May 26 11:05:59 systemd[1]: systemd-logind.service: start operation timed out. Terminating.
May 26 11:05:59 systemd[1]: systemd-logind.service: Failed with result 'timeout'.
May 26 11:05:59 systemd[1]: systemd-logind.service: Scheduled restart job, restart counter is at 3.
May 26 11:05:59 systemd[1]: Stopped User Login Management.
May 26 11:05:59 systemd[1]: Starting User Login Management...
May 26 11:05:59 systemd-logind[7625]: New seat seat0.
May 26 11:05:59 systemd[1]: Started User Login Management.



NetworkManager:

-- Boot 277b827965a9461eb976398c10bee096 --
May 26 11:04:30 systemd[1]: Starting Network Manager...
May 26 11:04:30 NetworkManager[4879]: <info>  [1621991070.1365] NetworkManager (version 1.30.4-1.fc34) is starting... (for the first time)
May 26 11:04:30 NetworkManager[4879]: <info>  [1621991070.1368] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf)
May 26 11:04:30 NetworkManager[4879]: <error> [1621991070.1377] bus-manager: cannot connect to D-Bus: Could not connect: Connection refused
May 26 11:04:30 NetworkManager[4879]: <info>  [1621991070.1377] exiting (error)
May 26 11:04:30 systemd[1]: NetworkManager.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:30 systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
May 26 11:04:30 systemd[1]: Failed to start Network Manager.
May 26 11:04:30 systemd[1]: NetworkManager.service: Scheduled restart job, restart counter is at 1.
May 26 11:04:30 systemd[1]: Stopped Network Manager.
May 26 11:04:30 systemd[1]: Starting Network Manager...
May 26 11:04:30 NetworkManager[4937]: <info>  [1621991070.3285] NetworkManager (version 1.30.4-1.fc34) is starting... (after a restart)
May 26 11:04:30 NetworkManager[4937]: <info>  [1621991070.3291] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf)
May 26 11:04:30 NetworkManager[4937]: <error> [1621991070.3344] bus-manager: cannot connect to D-Bus: Error receiving data: Connection reset by peer
May 26 11:04:30 NetworkManager[4937]: <info>  [1621991070.3345] exiting (error)
May 26 11:04:30 systemd[1]: NetworkManager.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:30 systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
May 26 11:04:30 systemd[1]: Failed to start Network Manager.
May 26 11:04:30 systemd[1]: NetworkManager.service: Scheduled restart job, restart counter is at 2.
May 26 11:04:30 systemd[1]: Stopped Network Manager.
May 26 11:04:30 systemd[1]: Starting Network Manager...
May 26 11:04:30 NetworkManager[5014]: <info>  [1621991070.5329] NetworkManager (version 1.30.4-1.fc34) is starting... (after a restart)
May 26 11:04:30 NetworkManager[5014]: <info>  [1621991070.5329] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf)
May 26 11:04:30 NetworkManager[5014]: <error> [1621991070.5360] bus-manager: cannot connect to D-Bus: Error sending credentials: Error sending message: Broken pipe
May 26 11:04:30 NetworkManager[5014]: <info>  [1621991070.5361] exiting (error)
May 26 11:04:30 systemd[1]: NetworkManager.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:30 systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
May 26 11:04:30 systemd[1]: Failed to start Network Manager.
May 26 11:04:30 systemd[1]: NetworkManager.service: Scheduled restart job, restart counter is at 3.
May 26 11:04:30 systemd[1]: Stopped Network Manager.
May 26 11:04:30 systemd[1]: Dependency failed for Network Manager.
May 26 11:04:30 systemd[1]: NetworkManager.service: Job NetworkManager.service/start failed with result 'dependency'.



DBus shows the following - which doesn't provide much around why I'm seeing the failures with the newer kernels - this error just repeats until the service eventually starts, but nothing seems to be able to actually get a connection

DBus
-- Boot 277b827965a9461eb976398c10bee096 --
May 26 11:01:56 systemd[1]: Starting D-Bus System Message Bus...
May 26 11:01:56 systemd[1]: Started D-Bus System Message Bus.
May 26 11:01:56 dbus-broker-lau[490]: Ready
May 26 11:04:25 systemd[1]: Starting D-Bus System Message Bus...
May 26 11:04:25 dbus-broker-launch[2927]: Non unix-domain-socket passed as listener
May 26 11:04:25 systemd[1]: dbus-broker.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:25 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:25 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:25 systemd[1]: Starting D-Bus System Message Bus...
May 26 11:04:25 dbus-broker-launch[2959]: Non unix-domain-socket passed as listener
May 26 11:04:25 systemd[1]: dbus-broker.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:25 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:25 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:25 systemd[1]: Starting D-Bus System Message Bus...
May 26 11:04:25 dbus-broker-launch[2975]: Non unix-domain-socket passed as listener
May 26 11:04:25 systemd[1]: dbus-broker.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:25 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:25 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:25 systemd[1]: Starting D-Bus System Message Bus...
May 26 11:04:25 dbus-broker-launch[3009]: Non unix-domain-socket passed as listener
May 26 11:04:25 systemd[1]: dbus-broker.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:25 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:25 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:25 systemd[1]: Starting D-Bus System Message Bus...
May 26 11:04:25 dbus-broker-launch[3035]: Non unix-domain-socket passed as listener
May 26 11:04:25 systemd[1]: dbus-broker.service: Main process exited, code=exited, status=1/FAILURE
May 26 11:04:25 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:25 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:25 systemd[1]: dbus-broker.service: Start request repeated too quickly.
May 26 11:04:25 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:25 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:29 systemd[1]: dbus-broker.service: Start request repeated too quickly.
May 26 11:04:29 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:29 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:29 systemd[1]: dbus-broker.service: Start request repeated too quickly.
May 26 11:04:29 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:29 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:29 systemd[1]: dbus-broker.service: Start request repeated too quickly.
May 26 11:04:29 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:29 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:30 systemd[1]: dbus-broker.service: Start request repeated too quickly.
May 26 11:04:30 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:30 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:04:30 systemd[1]: dbus-broker.service: Start request repeated too quickly.
May 26 11:04:30 systemd[1]: dbus-broker.service: Failed with result 'exit-code'.
May 26 11:04:30 systemd[1]: Failed to start D-Bus System Message Bus.
May 26 11:05:59 systemd[1]: Starting D-Bus System Message Bus...
May 26 11:05:59 systemd[1]: Started D-Bus System Message Bus.
May 26 11:05:59 dbus-broker-lau[7626]: Ready
May 26 11:07:47 dbus-broker[7627]: Dispatched 1497 messages @ 4(±19)μs / message.

Comment 24 Justin M. Forbes 2021-05-26 11:49:40 UTC
*** Bug 1964866 has been marked as a duplicate of this bug. ***

Comment 25 Fedora Update System 2021-05-26 16:17:06 UTC
FEDORA-2021-bb5e43a5a4 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-bb5e43a5a4

Comment 26 Fedora Update System 2021-05-26 16:17:07 UTC
FEDORA-2021-a35b44fd9f has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a35b44fd9f

Comment 27 Justin M. Forbes 2021-05-26 16:52:40 UTC
*** Bug 1965048 has been marked as a duplicate of this bug. ***

Comment 28 RedBearAK 2021-05-26 17:05:41 UTC
My bug report (1965048) was just marked a duplicate of this one, and it looks like it is. 

But I had an even worse problem after I tried following the instructions and installing the latest rawhide kernel (it pulled in packages like this: "kernel-core-5.13.0-0.rc2.19.fc35.x86_64"). 

This kernel brought me (after rebooting) to a completely black screen with a mouse cursor. When I tried clicking with the mouse cursor on the spot where my user name would normally appear at the login screen, I got the same hard system freeze and fans ramping to maximum speed.

Comment 29 Albert Flügel 2021-05-26 18:28:23 UTC
I tried now 5.13.0-0.rc3.25.fc35. Worse than before. E.g. starting thunderbird makes the UI freeze. Repeatedly. One time i was able to login from remote via ssh and found Xwayland a defunct process.  Killing was not possible (as expected), however, when i tried kill -9, the entire system froze. I'll switch to Xorg (don't know anyway why we need wayland), but assume, this will not help with this problem.
The history of my experiences with this issue (cause partially reported in 1963316, what was marked a dup):
* System freezes as soon as gdm starts after booting 5.12.5 or 5.12.6.
* Booting with gdm disabled works, but as soon as starting a display manager, the system hangs
* With 5.13.0-0.rc2.20210521git79a106fc6585.22.fc35.x86_64 gdm started and i could logon
* System freezes after half an hour when going fullscreen of a browser
* Now with 5.13.0-rc3 see above
Is this really just one issue ? So different phenomenons and different degrees of malfunctions and especially duration until UI freeze.
As far as i have read it is an issue with the driver for the intel i915 graphics chip. Why had it to be changed / broken ? Kernel 5.12.5 and 5.12.6 have been released to the Fedora Updates repo, though there are obviously severe issues. Where is QA ? Can anyone explain me, why the driver of a chip that was produced 12+ years ago must be fiddled with today making well-functioning systems unusable for an unforeseeable time ?
I vote for reverting the driver to the status of 5.11 as a "fix".

Comment 30 Fedora Update System 2021-05-27 01:32:24 UTC
FEDORA-2021-a35b44fd9f has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a35b44fd9f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a35b44fd9f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 31 Fedora Update System 2021-05-27 01:39:37 UTC
FEDORA-2021-bb5e43a5a4 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-bb5e43a5a4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-bb5e43a5a4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 32 John Apple II 2021-05-27 01:58:47 UTC
I've checked rawhide as well, and the 5.13 rawhide kernel has the same issues on my system as the 5.12.5-300 and 5.12.6-300 kernels. DBus won't boot, no networking available, and no logind function on either set of kernels.  Last working kernel for me is still 5.11.21-300

Comment 33 Andreas 2021-05-27 08:43:39 UTC
I was having similar problems with the ones reported here. Fedora wouldn't boot, the boot process would hang at:
Failed to start Switch Root

The issues started with the upgrade to kernel 5.12.5-300 and persisted with 5.12.6-300. I was able to boot the system by selecting 5.11.21-300 or an older kernel. What fixed it for me was downgrading dracut to 053-4.fc34 and regenerating the initramfs for the new kernels. For example:
sudo dracut --kver 5.12.5-300.fc34.x86_64 --force

After this the new kernels boot. So I'm not sure if this is the same bug as the one reported here, but I thought I would report it in case it helps others.

Comment 34 Justin M. Forbes 2021-05-27 12:20:38 UTC
For those trying various rawhide kernels. Anything rc2 is not expected to have a fix for this issue in it. Anything newer could also have other issues, 5.13 is still fairly early in the release cycle. That was why I posted builds of 5.12 kernels with a test fix.

As to where was QA, we had a test week, and the rebases sat in updates-testing for a bit before being pushed. This issue was not noted during test week, and only seen by one user in updates testing. At the same time, that rebase was noted as fixing things for several users that were broken during 5.11. Fedora is community driven.  It seems most of the people with impacted hardware weren't testing.  Anyway, 5.12.7 is in updates-testing heading to stable, and should fix the gdm issue on i915. If your issue is not that, please open another bug.

Comment 35 John Apple II 2021-05-27 16:09:15 UTC
(In reply to Andreas from comment #33)
> I was having similar problems with the ones reported here. Fedora wouldn't
> boot, the boot process would hang at:
> Failed to start Switch Root
> 
> The issues started with the upgrade to kernel 5.12.5-300 and persisted with
> 5.12.6-300. I was able to boot the system by selecting 5.11.21-300 or an
> older kernel. What fixed it for me was downgrading dracut to 053-4.fc34 and
> regenerating the initramfs for the new kernels. For example:
> sudo dracut --kver 5.12.5-300.fc34.x86_64 --force
> 
> After this the new kernels boot. So I'm not sure if this is the same bug as
> the one reported here, but I thought I would report it in case it helps
> others.

Yep, downgrading dracut and forcing a rebuild after the failed boot fixed it.

I found instructions here first, and then confirmation from you: https://www.reddit.com/r/Fedora/comments/nkjxls/512_kernel_broken/

Looks like it's no the kernel at all, it's dracut breaking dbus.

Now 5.12.7-300 is working fine.

Comment 36 RedBearAK 2021-05-27 18:53:23 UTC
The suggested dracut "downgrade and force" fix from the Reddit link did not work for me, on a 2007 MacBook3,1 with Intel 965GM graphics (according to the About page in the GNOME settings app). Booting from 5.12.6-300 still produced a hard freeze at login screen. 

But the 5.12.7-300.fc34 testing update finally installed for me, and even after allowing dracut to re-update to latest version at the same time I'm having no problems. 

System doesn't lock up at login screen, and since this seems to be related to the graphics driver I've been playing some YouTube videos (which this ancient integrated GPU can't do very well even at 360p, but I've pushed it all the way to 720p and it still "works") and having no real difficulties. 

System has been up for over half an hour now, web browsing, playing Spotify and playing videos on YouTube with no apparent issues.

Comment 37 Fedora Update System 2021-05-28 01:00:31 UTC
FEDORA-2021-a35b44fd9f has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 38 Fedora Update System 2021-05-28 01:11:08 UTC
FEDORA-2021-bb5e43a5a4 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 39 Roel 2021-05-28 06:16:13 UTC
For Info: 
On DELL E4300 Fedora 34 With kernels, Kernel-5.12.5-300.fc34.x86_64, Kernel-5.12.6-300.fc34.x86_64
GDM, Lightdm and lxdm al "freeze" have to do a hard reset.


Kernel-5.11.21-300.fc34.x86_64 works.

Yours kindly Omer

Comment 40 please delete this account 2021-05-28 06:57:17 UTC
(In reply to d.sch from comment #8)
> I've got a similar effect with an old hp compaq 6910p> booting to graphical desktop of vmlinuz-5.12.5-300.fc34.x86_64 or
> vmlinuz-5.12.6-300.fc34.x86_64 -> freezes after 2-5 secs
…


what a nice birthday present:

I just upgraded to vmlinuz-5.12.7-300.fc34.x86_64
and can confirm that the freezes of 5.12.5 and 5.12.6 I experienced are gone

actually I'm writing this by using 5.12.7

thanks to all the engaged people who helped to solve this

Comment 41 Aleksandar Kostadinov 2021-05-28 08:38:02 UTC
For me kernel-core-5.12.6-300.fc34.x86_64 freezed right after switch root in boot process while 5.11 worked fine. Now 5.12.7 seems to work:

> $ uname -a
> Linux koTak 5.12.7-300.fc34.x86_64 #1 SMP Wed May 26 12:58:58 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Comment 42 chuck elliot 2021-05-28 09:02:52 UTC
5.12.5-200.fc33.x86_64 and 5.12.6-200.fc33.x86_64 were freezing
for me during graphical login at user select phase.

5.12.7-200.fc33.x86_64 is working for me too on Samsung Q45.

Many thanks for the fast fix.

Comment 43 Albert Flügel 2021-05-28 09:45:34 UTC
Confirm, that 5.12.7-200 runs without issue for several hours now on Lenovo T500.
I don't want to believe, that a failing D-Bus makes the kernel freeze, what is implied in comments #33 and #35. Either it is the other way round and the freeze actually happens in several steps or it is a different bug.

Comment 44 cornel panceac 2021-05-28 10:06:05 UTC
I confirm i was able to login using the new kernel (5.2.17-300). Thank you for fixing this.

Comment 45 Justin M. Forbes 2021-05-28 13:54:38 UTC
*** Bug 1965533 has been marked as a duplicate of this bug. ***

Comment 46 Roel 2021-05-28 21:23:27 UTC
Confirm DELL E4300 works again after update to kernel 5.12.7-300.

Thank You.

Comment 47 rtqate 2021-05-28 22:20:50 UTC
5.12.7-300 is not working for me - I can log in, but the apps are still not loading (Firefox dind't load, for example). I tried to use Gnome terminal, and the desktop froze. 
I'll continue trying new kernels, while using 5.11.21. Thanks!

Comment 48 James Tabor 2021-05-30 18:40:32 UTC
Update to 5.12.7-200.fc33.x86_64 works okay. Normal applications used here seems normal.

System, HP G72 Notebook, Pentium Dual-Core CPU, 4G.

Comment 49 John Apple II 2021-05-31 01:42:04 UTC
(In reply to RedBearAK from comment #36)
> The suggested dracut "downgrade and force" fix from the Reddit link did not
> work for me, on a 2007 MacBook3,1 with Intel 965GM graphics (according to
> the About page in the GNOME settings app). Booting from 5.12.6-300 still
> produced a hard freeze at login screen. 
> 
> But the 5.12.7-300.fc34 testing update finally installed for me, and even
> after allowing dracut to re-update to latest version at the same time I'm
> having no problems. 
> 
> System doesn't lock up at login screen, and since this seems to be related
> to the graphics driver I've been playing some YouTube videos (which this
> ancient integrated GPU can't do very well even at 360p, but I've pushed it
> all the way to 720p and it still "works") and having no real difficulties. 
> 
> System has been up for over half an hour now, web browsing, playing Spotify
> and playing videos on YouTube with no apparent issues.

If you upgraded to the newer dracut only after the new kernel install, you'll be using the configuration and files created by the older dracut.  You likely won't see an issue (if you were hitting the bug I was hitting with dracut) until you install a newer kernel and dracut rebuilds the kernel configs.  You can prove this by executing `sudo dracut --force` on your working kernel and see if you fail (make sure you have a backup kernel before you do this, as NetworkManager refused to come up after the newer dracut build).

> Confirm, that 5.12.7-200 runs without issue for several hours now on Lenovo T500.
> I don't want to believe, that a failing D-Bus makes the kernel freeze, what is implied in comments #33 and #35. Either it is the other way round and the freeze actually happens in several steps or it is a different bug.

Yes, I think it is a different bug based on what I'm reading.  I'll raise a new one if I don't see a dup for the dracut issues I've been facing already live.

Comment 50 John Apple II 2021-05-31 01:54:20 UTC
I couldn't find a dracut related BZ for the item I discovered, so I've raised https://bugzilla.redhat.com/show_bug.cgi?id=1965859 with my boot information attached.

Comment 51 rtqate 2021-06-02 20:34:36 UTC
Installed 5.12.8-300.fc34.x86_64 with all the latest updates, and it's working (haven't noticed anything unusual so far). So I'm back on the latest kernel again, thanks!

Comment 52 rtqate 2021-06-03 04:19:09 UTC
After a few hours of use - I had to switch back to 5.11.21-300.fc34.x86_64, because some apps are still not working. VS Code (doesn't start) and VIM appear to have problems. The desktop freezes after I tried to use these apps. The issue reproduced a couple of times. It looks like 5.12 is still too new for any practical use, at least on my Dell laptop.

Comment 53 Albert Flügel 2021-06-03 08:47:29 UTC
For those experiencing any kind of freeze: It is important to distinguish, what actually is freezing: The kernel or some process. This can be a single vim or the entire graphical user interface. Regarding the latter i had opened bug 1941696 a while ago, cause i see regularly short hangs or delayed display updates for some seconds, what is really annoying, i assume a bug in some X11 related library, thus another new damage in old software.
So when you experience your system is stuck, please check, if you can switch to a different console (e.g. by Ctrl-Alt-F3). If possible, also please check, whether you can ping your system from a different node in your network or even login using ssh and check the status of the processes (ps ... you know). Depending on the observations it can imo be decided, whether this bug should be reopened or if it is something different.

Comment 54 Albert Flügel 2021-06-06 12:31:30 UTC
Just had a kernel freeze with 5.12.8-200 on a Lenovo T500. i don't consider the issue solved and vote for
* reopening this issue
* reverting the i915 driver to the 5.11 status.

Comment 55 Michael Stein 2021-06-07 06:36:20 UTC
+1
Kernel 5.12.8-300.fc34 freezes at "switch root" on my Dell XPS 15.

Comment 56 Aleksandar Kostadinov 2021-06-07 10:51:39 UTC
Some people reported the switch root issue is dracut related, although 5.12.7 fixed that for me.

For anybody with UI freezes, please make sure you're using the "Intel" driver as explaine in this blog [1]. In the past I had temporary display disconnect issues with the default X11 driver and since I'm using the proper "Intel" driver, things are good.

[1] https://hobo.house/2018/05/18/fix-for-intel-i915-gpu-freeze-on-recent-linux-kernels/

Comment 57 Albert Flügel 2021-06-08 17:51:35 UTC
As the writer of the mentioned blog says:
"Here’s my temporary fix on Fedora 28 for getting things stable again until it’s fixed for good upstream."
This is a workaround. And it is not clear, if this has really the same cause like this bug report.

Is it really intended to let people trying to install and run Fedora with one of the affected graphics chips go through all this hassle, search around in the internet and then apply this workaround ?
Or will the distro have to catch this ?

Comment 58 rtqate 2021-06-08 20:08:57 UTC
Tried kernel-core-5.12.9-300.fc34.x86_64 - still not usable (VS Code froze after launch, and so did Gnome a few seconds after). I'm back to 5.11.21.

Comment 59 froggy 2021-06-10 17:09:19 UTC
Having the same problem (ever since updating to kernel 5.12) on my thinkpad t490s running fedora 34 workstation. 
Tried multiple proposed solutions, none of which worked, including downgrading dracut. 
All 5.12 kernels (up to 5.12.9) always freeze at "switch root", after the trowing in errors like "failed to start dbus system message bus" etc.
5.11 kernels boot just fine. I read the article posted by Albert Fluegel. My latop has the Mesa Intel® UHD Graphics 620 (WHL GT2), but I find the proposed workaround in the article also too much hassle.
I hope this bug will be fixed soon, or either with next kernel release.

Comment 60 Mike Hepburn 2021-06-13 06:00:20 UTC
I had same symptoms with 5.12.X kernel - hanging at "Switch Root"

worked fine on 5.11.X, using Dell XPS 15, fc34 - using i915 and nvidia gpu loaded later

The dracut downgrade worked for me - thanks John - jappleii !

my workaround:


# whilst running in kernel-5.11.19-300.fc34.x86_64
# donwgrade dracut-054-12.git20210521.fc34.x86_64 -> dracut-053-4.fc34.x86_64
dnf downgrade dracut

# kernel-core-5.12.9-300.fc34.x86_64
dnf reinstall kernel-*-5.12*
dnf versionlock add dracut-053-4.fc34.x86_64
```

# for reference
my grub cmd line:

GRUB_CMDLINE_LINUX="i915.modeset=1 modprobe.blacklist=nvidia_drm,nvidia_modeset,nvidia quiet rhgb rd.driver.blacklist=nouveau"

am typing this comment now from:

$ uname -a
Linux virt 5.12.9-300.fc34.x86_64 #1 SMP Thu Jun 3 13:51:40 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Cheers

Comment 61 Michael Stein 2021-06-14 06:23:35 UTC
Downgrading to old dracut and rebuild the initramfs fixed the problem for me.

```
sudo dnf install dracut-053-4.fc34
export LATEST_KERNEL="5.12.9-300.fc34.x86_64"
sudo cp /boot/initramfs-${LATEST_KERNEL}.img /boot/initramfs-${LATEST_KERNEL}.bak.$(date +%m-%d-%H%M%S).img
sudo dracut -f /boot/initramfs-${LATEST_KERNEL}.img ${LATEST_KERNEL}
```

thanx to all for your investigation

Comment 62 Sathiyamoorthy Kothandan 2021-06-15 16:42:27 UTC
I was trying to downgrade from Fedora 34 to 33 and now system is not usable.

Steps:
1)dnf system-upgrade download  --releasever=33 --allowerasing --skip-broken
2)rpm --nodeps -e iptables-legacy-libs to resolve Error: Transaction test error:
  file /usr/lib64/libip4tc.so.2.0.0 from install of iptables-libs-1.8.5-5.fc33.x86_64 conflicts with file from package iptables-legacy-libs-1.8.7-4.fc34.x86_64
3)dnf system-upgrade reboot
4)at the boot it keep spinning and system is not usable

Comment 63 Aleksandar Kostadinov 2021-06-17 17:08:18 UTC
Now with 5.12.10-300.fc34.x86_64 issue is back. Freeze after `Switch Root` is printed on console. This is a workaround:

> sudo dnf downgrade dracut
> sudo dracut --force /boot/initramfs-5.12.10-300.fc34.x86_64.img 5.12.10-300.fc34.x86_64

For anybody that still hit it, please report to Bug 1973370

Comment 64 froggy 2021-06-18 13:26:50 UTC
I accidentally updated dracut (forgot --exclude=dracut*), and the issue is gone running kernel 5.12.10.

Installed Packages
dracut.x86_64                         054-12.git20210521.fc34           @updates
dracut-config-rescue.x86_64           054-12.git20210521.fc34           @updates
dracut-live.x86_64                    054-12.git20210521.fc34           @updates
dracut-network.x86_64                 054-12.git20210521.fc34           @updates
kernel-core.x86_64                    5.11.21-300.fc34                  @updates
kernel-core.x86_64                    5.12.9-300.fc34                   @updates
kernel-core.x86_64                    5.12.10-300.fc34                  @updates

ps: previously, the solutions posted by Mike Hepburn & Michael Stein worked for me (reinstall kernel after downgraded dracut)

Comment 65 rtqate 2021-06-19 20:08:12 UTC
5.12.11-300.fc34.x86_64 seems to work for me. I did't downgrade dracut, just installed today's updates, including the 5.12.11 kernel. There have been no problems at all so far.

Comment 66 froggy 2021-06-21 13:54:47 UTC
The switch root issue is back with 5.12.11-300.fc34.
Running 5.12.10 has no issues. Dracut version is 054-12.git20210521.fc34.

Comment 67 froggy 2021-06-21 14:08:46 UTC
rest of my comments on Bug 1973370

Comment 68 rtqate 2021-06-22 19:25:35 UTC
dracut upgraded (came with a separate # dnf update), all is working well (at least, so far). Hope this helps, thanks!


Note You need to log in before you can comment on or make changes to this bug.