Bug 1963871 - cluster-etcd-operator:[build] upgrade to go 1.16
Summary: cluster-etcd-operator:[build] upgrade to go 1.16
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.8.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-24 09:41 UTC by Sam Batschelet
Modified: 2021-07-27 23:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-27 23:09:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 599 0 None closed Bug 1963871: Move back to Golang 1.15 as in o/release 2021-05-24 13:04:33 UTC
Github openshift cluster-etcd-operator pull 602 0 None open Bug 1963871: bump(*): Update the go version to 1.16 2021-05-31 22:27:27 UTC
Github openshift cluster-etcd-operator pull 607 0 None open Bug 1963871: .ci-operator.yaml: Use golang-1.15 tag 2021-05-31 15:16:00 UTC
Github openshift release pull 18621 0 None open Bug 1963871: cluster-etcd-operator: get build_root from repo 2021-05-24 13:04:34 UTC
Red Hat Product Errata RHSA-2021:2438 0 None None None 2021-07-27 23:10:03 UTC

Description Sam Batschelet 2021-05-24 09:41:35 UTC
Description of problem: cluster-etcd-operator is currently built using golang 1.15.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: cluster-etcd-operator is built using golang 1.16


Additional info:

Comment 2 ge liu 2021-06-10 10:28:41 UTC
The version updated in go.mod and merged in build already, I suppose this issue have been fixed.

Comment 6 errata-xmlrpc 2021-07-27 23:09:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.8.2 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2021:2438


Note You need to log in before you can comment on or make changes to this bug.