Bug 1963956 - Add a logrotate entry for /var/log/foreman-maintain
Summary: Add a logrotate entry for /var/log/foreman-maintain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.9.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: 6.10.0
Assignee: Amit Upadhye
QA Contact: Gaurav Talreja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-24 13:28 UTC by Pavel Moravec
Modified: 2021-11-16 13:48 UTC (History)
7 users (show)

Fixed In Version: rubygem-foreman_maintain-0.8.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-16 13:48:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 33193 0 Normal New Add a logrotate entry for /var/log/foreman-maintain 2021-07-30 13:29:57 UTC
Red Hat Product Errata RHBA-2021:4697 0 None None None 2021-11-16 13:48:12 UTC

Description Pavel Moravec 2021-05-24 13:28:56 UTC
Description of problem:
foreman-maintain tool can easily generate a lot of logs (i.e. when used as a services check tool every few minutes). Default Satellite deployment should housekeep those logs automatically, similarly like e.g. /var/log/foreman or /var/log/foreman-proxy .

Please provide in part of foreman-maintain package a file like (copy from foreman logs):

# cat /etc/logrotate.d/foreman-maintain
# Foreman-maintain logs:
/var/log/foreman-maintain/*.log {
  daily
  missingok
  rotate 14
  compress
  delaycompress
  notifempty
  copytruncate
}
#


Version-Release number of selected component (if applicable):
Sat6.9


How reproducible:
100%


Steps to Reproduce:
1. Repeatedly run "foreman-maintain service status" or any other f-m command
2. Check that the /var/log/foreman-maintain/foreman-maintain.log* logs are never logrotated / housekept.


Actual results:
2. No logrotation.


Expected results:
2. Some reasonable logrotation (not necessarily the one I suggested).


Additional info:

Comment 2 Bryan Kearney 2021-07-30 20:04:11 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/33193 has been resolved.

Comment 3 Bryan Kearney 2021-07-30 20:05:20 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/33193 has been resolved.

Comment 5 Gaurav Talreja 2021-09-01 19:05:42 UTC
Verified.

Tested on Satellite 6.10.0 Snap 16.0
Version: rubygem-foreman_maintain-0.8.13-2.el7sat.noarch

Steps:
1. # rpm -qc rubygem-foreman_maintain
2. # cat /etc/logrotate.d/foreman_maintain
3. # ll -h /var/log/foreman-maintain/

Observation:
Logs under /var/log/foreman-maintain/*.log are being rotated `daily` and has same logrotate config as /var/log/foreman and /var/log/foreman-tasks.

Comment 8 errata-xmlrpc 2021-11-16 13:48:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Satellite 6.10 Satellite Maintenance Release), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4697


Note You need to log in before you can comment on or make changes to this bug.