Bug 196398 - named not dbus-enabled by default
named not dbus-enabled by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-22 18:40 EDT by Derek Atkins
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 05:30:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Atkins 2006-06-22 18:40:40 EDT
Description of problem:
The default configuration of named does not enable dbus support.  I would have
expected named to get the '-D' option by default.

Version-Release number of selected component (if applicable):
bind-9.3.2-20.FC5
bind-config-9.3.2-20.FC5


How reproducible:
100%

Steps to Reproduce:
1. install bind and bind-config
2. /etc/init.d/named start
3. notice that named doesn't have dbus support.
  
Actual results:
named is run with only "-u named" and without -D by default

Expected results:
What with NetworkManager and all, I would have expected named to get -D by
default in the release.

Additional info:

Just add this to the default /etc/sysconfig/named file:

OPTIONS="-D"
Comment 1 Jason Vas Dias 2006-07-19 17:34:34 EDT
Now fixed with bind-9.3.2-30.fc6 and bind-9.3.2-22.fc5 .
The named initscript will now check if the NetworkManager service is enabled
in any runlevel, and will then ensure the '-D' option is in $OPTIONS if so.
Comment 2 Florian La Roche 2006-07-20 07:47:27 EDT
Can we allow an option override for this via some sysconfig file, so that
it stays an option to specify the behaviour to off?

Also checking NM in all runlevels looks like a bit too much. Also if
-D is alsoready given, all remaining checks could be left away, so that
could move to be the first check.

regards,

Florian La Roche
Comment 3 Jason Vas Dias 2006-07-20 14:35:55 EDT
Yes, the initscript check does already check if -D is already specified.

I've now put the test for NM after the test for -D, and added the 
'DISABLE_NAMED_DBUS' /etc/sysconfig option - the named.init code 
to do this is now like this in CVS:

---
dbusEnabled=0;
for a in $OPTIONS; do
    if [ $a  = "-D" ]; then
        dbusEnabled=1;
    fi;
done

if [ $dbusEnabled -eq 0 ] && [ -z "$DISABLE_NAMED_DBUS" ] ; then
    NetworkManagerEnabled=0
    for l in 0 1 2 3 4 5 6; do
        if /sbin/chkconfig --level=$l NetworkManager >/dev/null 2>&1; then
            NetworkManagerEnabled=1;
        fi;
    done
    if [ $NetworkManagerEnabled -eq 1 ]; then
        OPTIONS="$OPTIONS -D";
    fi;
    dbusEnabled=1;
fi
---

I'll submit this to FC-6 + FC-5 shortly.
Comment 4 Fedora Update System 2006-07-22 15:00:12 EDT
bind-9.3.2-22.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Matthias Clasen 2006-09-21 23:24:37 EDT
Jason, this is fixed ?
Comment 6 Martin Stransky 2006-09-22 05:30:44 EDT
It's fixed in bind-9.3.2-33.fc5 / bind-9.3.3-1.fc6

Note You need to log in before you can comment on or make changes to this bug.