Bug 19641 - if GATEWAY in ifcfg-ethX, duplicate default routes are added
if GATEWAY in ifcfg-ethX, duplicate default routes are added
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 17:58 EDT by Pekka Savola
Modified: 2014-03-16 22:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 07:19:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-10-23 17:58:01 EDT
If you use GATEWAY= in ifcfg-ethX (e.g. netconfig does this), 
duplicate default routers will be added (one with metric 1, one with metric 0), 
unless you have the following line in /etc/sysconfig/network:

GATEWAY=

 .. This is caused by the following in /sbin/ifup:

---
    # this is broken! it's only here for compatibility with old RH systems
    if [ "${GATEWAY}" != "" -a "${GATEWAY}" != "none" ]; then
        route add default gw ${GATEWAY} metric 1 ${DEVICE}
    fi
---

Happens in both RHL62 and RHL70.
Comment 1 Bill Nottingham 2001-01-29 19:00:57 EST
The code will be removed as of 5.60-1.

Note You need to log in before you can comment on or make changes to this bug.