Bug 196418 - pup windows frozen while downloading
pup windows frozen while downloading
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-23 01:25 EDT by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 18:24:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2006-06-23 01:25:26 EDT
Description of problem:

Been experimenting with FC6t1, and finally found a subset of updates
it didn't complain about dependency errors on, but once it started the
update and put up the "Downloading packages" dialog with the progress bar,
the windows froze. It never indicated any progress or refreshed any window
while doing the (extremely long) downloads. Only by running a network
monitor or looking at the /var/cache/yum directories could I tell anything
was happening.

This was all immediately following an install off the DVD, so the versions
of software involved are whatever was shipped with FC6t1.
Comment 1 Bryan Bell 2006-06-25 12:54:46 EDT
Does the same thing happen with FC5?, I noticed that the progress bar for pirut
an d pup only updates  when a package finishes downloading(this is because they
didn't use multithreading for the progress bar so it blocks on the download). 
Comment 2 Tom Horsley 2006-06-25 15:43:42 EDT
Don't know. I suppose I could give it a try next time I update my FC5
system (but I normally use yumex on FC5 and would on FC6 as well if only
it worked :-).
Comment 3 Jeremy Katz 2006-06-25 20:50:34 EDT
Multithreading isn't the only answer here... we should be getting proper
callbacks so that we can do updates without needing a thread.  I'll look into
what's going wrong on the download side.
Comment 4 Jeremy Katz 2006-09-11 18:24:14 EDT
Callbacks weren't being set up properly in yum, fixed in yum cvs

Note You need to log in before you can comment on or make changes to this bug.