Bug 196419 - 2nd sata drive doesn't seem to work
2nd sata drive doesn't seem to work
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 01:38 EDT by Tom Horsley
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 19:07:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of system boot messages (27.09 KB, text/plain)
2006-06-24 21:17 EDT, Tom Horsley
no flags Details
new log of boot with 2356 kernel (28.08 KB, text/plain)
2006-07-06 21:59 EDT, Tom Horsley
no flags Details
yet another boot log for 2401 kernel this time (32.67 KB, text/plain)
2006-07-15 21:52 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2006-06-23 01:38:03 EDT
Description of problem:

I've got an ASUS A8N-E with 2 sata drives installed via the onboard nforce
sata controller. When I first installed FC6t1, it mounted all the /dev/sda
partitions OK, but didn't see the /dev/sdb2 partition. Attempting to mount
it manually always gave the error that it was busy or already mounted.

I ignored that and got a bunch of updates loaded, including the new kernel
(2293) and when I rebooted after that, it couldn't even boot cleanly, but
gives a bunch of errors right after saying something about starting
the logical volume manager (I'm not using LVM on either disk).

Haven't yet tried things like booting old kernel or commenting out the
fstab entry. Must get sleep now :-).
Comment 1 Tom Horsley 2006-06-23 09:23:01 EDT
OK, tried a few things. If I boot the original 2289 kernel, it does boot,
but still doesn't mount anything on the 2nd sata drive (I have two primary
partitions /dev/sdb1 is swap and /dev/sdb2 is ext3 and I see errors as the
boot messages scroll past on both). With the 2293 kernel it decides the
errors are too bad and wants the root password to go into maintainence mode.

If I comment out the /dev/sdb* entries in the /etc/fstab file, then the 2293
kernel can manage to boot.

Fedora Core 5 on the same machine, different boot partition, has no problems
with the two disks. Here's the fdisk -l from FC5 where they work:

fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14          26      104422+  83  Linux
/dev/sda3              27          39      104422+  83  Linux
/dev/sda4              40       19457   155975085    5  Extended
/dev/sda5              40        6541    52227283+  83  Linux
/dev/sda6            6542       13043    52227283+  83  Linux
/dev/sda7           13044       19457    51520423+  83  Linux

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        1020     8193118+  82  Linux swap / Solaris
/dev/sdb2            1021       19457   148095202+  83  Linux
Comment 2 Tom Horsley 2006-06-23 18:03:39 EDT
Just for the record, the new 2302 kernel doesn't want to talk to the 2nd drive
either.

I do see some kind of gibberish that looks like it might be important go past
in the boot messages, but it is off the screen before I can really take a look.
Is there any way to capture the boot messages short of setting up a serial
console and capturing the output on a different computer? (Which I can do
if someone really wants to see the messages, but it is a pain - I'd have to
find my buried null modem cable first :-).
Comment 3 Tom Horsley 2006-06-24 21:17:45 EDT
Created attachment 131492 [details]
log of system boot messages

Well, I found my null modem cable, and booted up FC6t1 with a serial console
so I could log the messages, and I have the feeling it has something to do
with the /sbin/kpartx crash that happens during boot. The fdisk -l output
later in the log also seems interesting since it appears to show the 2nd disk
twice, once as /dev/sdb and once as some sort of /dev/dm* nonsense.

I also notice a hcid crash when rebooting which probably has nothing to do with

this but maybe should be a separate bug.

Out of curiosity, I looked up the info for the rpm that owns /sbin/kpartx and
when that printed nothing but apparent gibberish, I followed the URL it gives
to another web page, also full of total gibberish, but with an FAQ link, so
I clicked on the FAQ only to discover they forgot the most fundamental FAQ of
all: "What in the blue blazes is this junk?" - it is still all gibberish
to me :-).
Comment 4 Tom Horsley 2006-07-06 21:59:13 EDT
Created attachment 132036 [details]
new log of boot with 2356 kernel

With latest 2356 kernel I don't get as many errors about the sdb
drive showing up, but I do get more things crashing duriing boot
(now a recursive lock in device-mapper).
Comment 5 Tom Horsley 2006-07-06 22:06:23 EDT
And the system still can't talk to the /dev/sdb drive. I tried re-enabling
the entries in fstab and it drops into single user again at boot time
with errors about the 2nd disk, so fewer error messages in the boot log
doesn't mean fewer errors :-).
Comment 6 Tom Horsley 2006-07-15 21:52:07 EDT
Created attachment 132516 [details]
yet another boot log for 2401 kernel this time

Its getting closer and closer to test2 time and the kernel seems to be getting
worse (at least on this system). I still get the recursive lock bug, and now
get additional kernel errors later in the boot and /dev/sdb still won't talk to
me and all these weird /dev/dm* things show up, so I'm bumping the priority to
high for this since these all seem like pretty serious problems from where I
sit :-).
Comment 7 Tom Horsley 2006-08-17 08:09:36 EDT
Well, I had problems with my system and have now gotten it running again
with a new motherboard and the latest FC6 test 2, and none of these
problems show up anymore. Maybe test2 is better, maybe it was just
the motherboard going (but both boards have the same chipset controlling
the same sata drives - was an ASUS A8N-E, is a Biostar TForce4U).

For whatever reason, looks like problem is gone.
Comment 8 Place Holder 2006-10-30 14:25:34 EST
I also have an ASUS motherboard with two SATA drives and I have not been able to
get any version of FC6 to work on it since FC6T1 (which I could not use for
other reasons.)  I used DBAN to wipe the first 5% of the two drives, installed
FC6_64 from the DVD with absolute minimum packages, and after rebooting after
finishing the install the system hangs on startup... I don't even see a GRUB:
prompt.  (On FC6T3 it used to hang at the GRUB: prompt where it would not accept
any input.)  I'm not sure how to actually debug this one.  The system will boot
and run a FC6 LiveSpin CD no problem.
Comment 9 Jon Stanley 2007-12-30 19:46:03 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Note You need to log in before you can comment on or make changes to this bug.