Bug 19642 - "Scope" visualisation mode displayed half-width
"Scope" visualisation mode displayed half-width
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 18:43 EDT by Need Real Name
Modified: 2014-03-16 22:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-15 18:45:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-23 18:43:53 EDT
Whilst an MP3 is playing with the "Scope" visualisation mode selected, the
waveform covers only the left-hand half of the scope area. A (stationary)
flat line is shown in the right-hand half.

Output is to an Opti MAD16 sound card, which is described in /dev/sndstat
as:

MAD16 WSS (82C930) (DUPLEX)

This bug is visible in versions of xmms upto and including 1.2.2, Linux
kernels upto and including 2.2.16-3. Sound output via OSS driver.
Comment 1 Bill Nottingham 2000-11-13 02:06:55 EST
Have you tried 1.2.3?  I can't reproduce this on the cards I've
tested on.
Comment 2 Need Real Name 2000-11-15 18:45:31 EST
I've just had a look at the problem again and have some more info for you:

 - With downsampling set to 1:1 (44kHz) in the "MPEG Layer 1/2/3 Player 1.2.3
[libmpg123.so]"
    input plugin, the waveform fills the entire display area, as it is supposed
to.
 - With downsampling set to 1:2 (22kHz) only the left-hand half of the display
has a waveform.
 - With downsampling set to 1:4 (11kHz) only the left-hand quarter of the
display has a waveform.

I normally use 1:2 (22kHz) for performance reasons.

I've not looked at the source, but from the program behaviour it looks as if
XMMS is providing a bigger buffer for the waveform data than is actually being
filled, leaving the rest as zeros. Yes, the problem is also present in
xmms-1.2.3-2 from RawHide.
Comment 3 Bill Nottingham 2001-02-01 12:38:20 EST
Ugly hack added in xmms-1.2.4-7.

Note You need to log in before you can comment on or make changes to this bug.