Bug 196422 - hugs98-2006.05-4.fc5 is not using readline
hugs98-2006.05-4.fc5 is not using readline
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hugs98 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 02:51 EDT by Mariano Suárez-Alvarez
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 11:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mariano Suárez-Alvarez 2006-06-23 02:51:19 EDT
Hugs no longer is using readline:

Main> :e
Main> ^[[A^[[A^[[A

Hugs becomes very very less usable without it!
Comment 1 Gérard Milmeister 2006-06-23 03:23:21 EDT
This is strange, readline is seen in configure, but hugs is not
linked against it... I will investigate.
Comment 2 Gérard Milmeister 2006-06-23 03:55:00 EDT
So I found the problem:
In this release I compile with the --enable-char-encoding=utf8 configure
option, but this excludes the use of readline.
Comment 3 Gérard Milmeister 2006-06-23 11:33:30 EDT
I made a new release with --enable-char-encoding=locale which
DOES have readline.
Comment 4 Mariano Suárez-Alvarez 2006-06-23 15:00:24 EDT
You should always follow the locale. People using UTF-8 (most of FC5 users, say)
will have their LANG variable correctly set.

When will you make a new release? I don't know what the release schedule is for
Extras for since this turned out to be a bad regression, maybe it's justified to
do a new one soonish ;-)

Note You need to log in before you can comment on or make changes to this bug.