Bug 196438 - IBM ServeRAID (IPS) driver fails to load on IBM RS/6000 7025-F50
IBM ServeRAID (IPS) driver fails to load on IBM RS/6000 7025-F50
Status: CLOSED DUPLICATE of bug 196437
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 06:10 EDT by Alexey Bozrikov
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 06:17:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Bozrikov 2006-06-23 06:10:50 EDT
Description of problem:
ips.ko driver fails to load on IBM 7025-F50 equipped with IBM ServeRAID 4H 4-
channel Ultra3 SCSI RAID controller. Following recorded in dmesg:
PCI: Enabling device 0001:40:0c.0 (0140 -> 0143)
 0:0:4:0: Attached scsi generic sg0 type 5
sd 1:0:8:0: Attached scsi generic sg1 type 0
sd 1:0:9:0: Attached scsi generic sg2 type 0
....skipped....
ips 0001:40:0c.0: unable to read config from controller.
ips 0001:40:0c.0: Unable to initialize controller
ips: probe of 0001:40:0c.0 failed with error -1

When I try to do 'modprobe ips' manually after system boot, different error is 
logged in dmesg:
[1st try]
ips 0001:40:0c.0: Couldn't allocate IO space feffe800 len 256.
ips: probe of 0001:40:0c.0 failed with error -1
[2nd try]
ips 0001:40:0c.0: Couldn't allocate IO Memory space d7f00000 len 1048576.
ips: probe of 0001:40:0c.0 failed with error -1


Controller particulars (lspci -v):
0001:40:0c.0 RAID bus controller: IBM SCSI RAID Adapter [ServeRAID] (rev 10)
        Subsystem: IBM ServeRAID-4H
        Flags: medium devsel, IRQ 23
        I/O ports at e4000800 [size=256]
        Memory at d7f00000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at d7eb8000 [disabled] [size=32K]
        Capabilities: [40] Vital Product Data
        Capabilities: [48] Power Management version 2

Version-Release number of selected component (if applicable):
Linux version 2.6.16-1.2133_FC5smp 
Kernel command line: root=/dev/md1 ro rhgb splash ips=debug:11

How reproducible:
always
Steps to Reproduce:
1. modprobe ips
2.
3.
  
Actual results:


Expected results:


Additional info: This does not seem to be pure hardware problem. When I boot 
IBM AIX operating system on the machine everything works fine, no errors.
Comment 1 Alexey Bozrikov 2006-06-23 06:17:11 EDT

*** This bug has been marked as a duplicate of 196437 ***

Note You need to log in before you can comment on or make changes to this bug.