Bug 196440 - cegui doc split package has non standard naming scheme
cegui doc split package has non standard naming scheme
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cegui (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 06:57 EDT by Rudolf Kastl
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 08:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2006-06-23 06:57:28 EDT
Description of problem:

actually you seem to name the doc split package cegui-devel-doc. this makes it
sound like a seperate cegui-devel src rpm would exist.

i am not sure if theres anything about that in the rpm guidelines, what i know
though is that this is not "common practice" atleast.

since you split off the docs from the cegui src rpm the in my eyes correct name
would be cegui-doc since cegui is the name of the main package.

Version-Release number of selected component (if applicable):
latest fc devel
Comment 1 Hans de Goede 2006-06-23 08:01:01 EDT
[hans@shalem vice]$ yum list '*devel-doc*'
Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files
Available Packages
cegui-devel-doc.i386                     0.4.1-8.fc6            extras-developme
cegui-devel-doc.x86_64                   0.4.1-8.fc6            extras-developme
qt-devel-docs.i386                       1:3.3.6-7              development-i386
qt-devel-docs.x86_64                     1:3.3.6-7              development     
[hans@shalem vice]$

As you can see other package with HUGE developer oriented (not end user)
documentation do the same.

Ian, feel free to close this as notabug.
Comment 2 Rudolf Kastl 2006-06-23 08:06:33 EDT
#1 if this is supposed to be the right approach i am pretty tempted to open bugs
with the other packages where its handled different then.

maybe its just me but more consitant behaviour would be nice.
Comment 3 Hans de Goede 2006-06-23 08:11:13 EDT
1) any examples of libraries with so HUGE development docs, the CEGUI docs way
in at a formidable 70 Mb or so.
2) If you want consistency for things like this don't start filing bugs like
crazy instead discuss it on the mailinglist, get guidelines added to the package
guidelines for this and then (and only then) you can start filing bugs.
Comment 4 Rudolf Kastl 2006-06-23 08:14:33 EDT
#3
1) splitting docs is a nice nice... there are other packages yet that pull in a
massive amount of docs... but since i cant find a guideline for splitting em i
wont file the bugs either

2) argument ackknowleged... closing bug and just putting my sunglasses on when i
look at the naming scheme so i dont get annoyed.
Comment 5 Hans de Goede 2006-06-23 08:18:19 EDT
(In reply to comment #4)
> #3
> 1) splitting docs is a nice nice... there are other packages yet that pull in a
> massive amount of docs... but since i cant find a guideline for splitting em i
> wont file the bugs either
> 

Actually the review guidelines are clear that if the docs are HUGE and not
nescesarry to function they should be split. Since the main function of a -devel
package is to compile things, I for one say that huge development docs shiould
be split from the -devel package. The only thing which isn't clear is how these
split docs should be called: package-doc or package-devel-doc.

So there are guidelines about splitting, just not about the name :)
Comment 6 Rudolf Kastl 2006-06-23 08:29:25 EDT
#5
if i had more time id reread those guidelines and start to get flamed on a
mailinglist with discussing that stuff...
but i will rather go back now fixing upstream code issues to get stuff ready for
fedora. this stuff can be taken care about by non coders (and in my eyes should).

i dont want to sound nitpicking etc... but is "huge" defined aswell?

actually the in my eyes "common naming scheme" since i started packaging with rh
7.x was basename-doc ... where as you use as basename the "name" of the package
src rpm for every split you do.

i just found it wierd to use the base for split as split package.

the way it currently is one can really do everything with the split package
splits it seems

stuff like name-devel-anothersubsplitnaming should be working too (like
name-devel-mysql for mysql relevant stuff split off from the devel package.)

maybe then even name-devel-mysql-docs for the relevant docs.

it just looks like from outer space to me.
Comment 7 Ian Chapman 2006-06-23 17:13:20 EDT
As far as I'm aware there's no official definition of huge, infact IIRC the 
packaging guidelines leave it up to the packager's common sense. I intend to 
leave it as is - unless there's official word to say otherwise.

Note You need to log in before you can comment on or make changes to this bug.