Bug 196452 - Anaconda no module named zonetab timezone setup
Anaconda no module named zonetab timezone setup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 09:46 EDT by Jasper O. Hartline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 09:58:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O. Hartline 2006-06-23 09:46:56 EDT
Description of problem:
When running Anaconda under Kadischi, Fedora Core's LiveCD generation utility,
after reaching timzone setup Anaconda dies with an exception, "no module named
zonetab".
Here is a snippet:
--------------------------------------------------------------------
14:45:05 INFO    : moving (1) to step timezone
14:45:05 CRITICAL: Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 962, in ?
    anaconda.intf.run(anaconda)
  File "/usr/lib/anaconda/text.py", line 512, in run
    rc = win(self.screen, instance)
  File "/usr/lib/anaconda/textw/timezone_text.py", line 65, in __call__
    timezones = self.getTimezoneList()
  File "/usr/lib/anaconda/textw/timezone_text.py", line 30, in getTimezoneList
    import zonetab
ImportError: No module named zonetab

14:45:06 INFO    : in run, screen = <snack.SnackScreen instance at 0xb7aca46c>

Version-Release number of selected component (if applicable):
anaconda-11.1.0.45-1

How reproducible:
Run Anaconda under Kadischi Fedora LiveCD generation utility.

Steps to Reproduce:
1. Run Anaconda under Kadischi
2.
3.
  
Actual results:
Exception in timezonesetup

Expected results:
Anaconda should run allowing a LiveCD to be built.

Additional info:
No additional information at this time.
Comment 1 Chris Lumens 2006-06-26 14:22:27 EDT
Is system-config-date installed?
Comment 2 Jasper O. Hartline 2006-06-26 18:40:10 EDT
No system-config-date is not installed.
I imagine that module is part of system-config-date?

Kadischi should perhaps have a requires on it then, since it does stop execution
if it doesn't exist. Anaconda can exist on a system without system-config-date
and it is a requires. This makes some sense.
Comment 3 Chris Lumens 2006-06-27 09:58:27 EDT
That is correct, it should require system-config-date.  I'll add a requires to
anaconda as well.

Note You need to log in before you can comment on or make changes to this bug.