Bug 1965 - Problems with sda3 (`Whole disk' partition)
Problems with sda3 (`Whole disk' partition)
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
5.2
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-03 13:15 EST by nathan
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-06 13:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nathan 1999-04-03 13:15:07 EST
Fdisk (during installation) prints a message about wanting
partition 3 to cover the whole disk and be of type 5
(Whole disk). However, it will not let me set the start
cylinder to 0.

What I did here was set the start on sda3 to the lowest
cylinder it would let me, set the end to the last cyl on
the disk, and changed the type to 5. Now, it will let me
add the remaining partitions over it, but sda3 is only
listed as cylinder 140-5044:

Disk /tmp/sda (Sun disk label): 5 heads, 186 sectors, 5044
cylinders
Units = cylinders of 930 * 512 bytes

   Device Flag   Begin    Start      End   Blocks   Id
System
/tmp/sda1            0        0       70    32550   83
Linux native
/tmp/sda2           70       70      140    32550   83
Linux native
/tmp/sda3          140      140     5044  2280360    5
Whole disk
/tmp/sda4  ur      140      140      280    65100   82
Linux swap
/tmp/sda5  ur      280      280     5044  2215260   83
Linux native

If this is the normal behaviour, it should be made more
obvious. `Whole disk', by definition, should be 0-5044
unless otherwise stated, no? Also, another problem: I
tried to add sd3 as 0-5044, type 5 before adding any
other partitions. I could then add a 0-+32M partition,
but sd2 wouldn't add on any starting cylinder (said
'Sector xx already allocated'). There is no escape out
of the prompt for First cylinder, so i had to break to
prom and reset the machine. Bug. :-)

I'm using fdisk because disk druid is confusing itself
about available space (i.e. i have 32M free, but not
enough to add a 32M partition). It should be more fine-
grained than Megabytes anyway.
Comment 1 Cristian Gafton 1999-10-06 13:04:59 EDT
Is this still a problem with 6.0 and/or 6.1 ? Please reopen if so.

Note You need to log in before you can comment on or make changes to this bug.