Bug 196512 - VLANs, tg3 driver, and 2.6.9-34.EL kernel update
VLANs, tg3 driver, and 2.6.9-34.EL kernel update
Status: CLOSED DUPLICATE of bug 188087
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-06-23 16:30 EDT by Robin Yamaguchi
Modified: 2013-03-06 00:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 23:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Yamaguchi 2006-06-23 16:30:02 EDT
Description of problem:

Since upgrading our RHEL4 boxes to the 2.6.9-34.EL kernel, we've experienced
problems with our virtual interfaces and VLAN tagged frames.  Before upgrading
to the kernel, our multi-homed box worked fine, dhcping for addresses on each
virtual interface.

Our two interfaces are eth0.75 and eth0.76, using a tg3 driver for an onboard
Broadcom Corporation NetXtreme BCM5751 Gigabit NIC.

After the kernel upgrade to 2.6.9-34.EL, eth0.75 is unable to DHCP for an IP
address.  The DHCP server never sees the DHCPDISCOVER.

However, eth0.76, also using tagged frames, is able to successfully DHCP for an
address.

Strangely, when I disable eth0.75 (using ONBOOT=no in ifcfg-eth0.75), and
restart the network service, eth0.76 can no longer DHCP.  Again, the DHCP server
never sees the DHCPDISCOVER.

I tried statically assigned an IP address, but the problemed interface still
wasn't able to see the network.  However, I am able to tcpdump, and I see the
apropriate ARP requests acrossed that tagged network.

I believe there is something wrong with the tg3 driver we are using for our NIC.
 I installed a PCI 3com NIC, setup virtual interfaces simularly, connected to
the same switch port as I was previously using, and virtual interfaces DHCP fine
with the latest kernels.

However, I tried downloading the source code for the latest tg3 driver from
broadcomm's website.  It compiled fine, but I continued to have the same problem. 

Version-Release number of selected component (if applicable):
2.6.9-34.EL and 2.6.9-34.0.1.EL.  This setup was working using 2.6.9-22.0.2.EL
and previous kernels.
 
How reproducible: Always

Here are the relevant files:

# more /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=localhost.localdomain
NISDOMAIN=<our_nis_domain>
GATEWAY=<our_gateway_ip>
VLAN=yes

# more /etc/sysconfig/network-scripts/ifcfg-eth0
# Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express
DEVICE=eth0
ONBOOT=no
BOOTPROTO=none
PEERDNS=no
TYPE=Ethernet

# more /etc/sysconfig/network-scripts/ifcfg-eth0.75 
DEVICE=eth0.75
BOOTPROTO=dhcp
ONBOOT=yes
PEERDNS=no

# more /etc/sysconfig/network-scripts/ifcfg-eth0.76 
DEVICE=eth0.76
BOOTPROTO=dhcp
ONBOOT=yes
PEERDNS=no
Comment 1 Jason Baron 2006-06-26 10:18:07 EDT
hmmm, can you try the rhel4 U4 beta kernel, thanks.

http://people.redhat.com/~jbaron/rhel4/
Comment 2 Robin Yamaguchi 2006-06-26 12:56:12 EDT
Installing 2.6.9-34.4.EL beta kernel seems to have fixed my problem!  Thank you!

I'm curious to know, what was the issue?
Comment 3 Jason Baron 2006-06-27 23:18:42 EDT
34.4? shouldn't it be -40? just curious what kernel you tried. I belive the fix
is bugzilla 188087, but i can double check for you if its really important.
thatnks for testing this for us :)

*** This bug has been marked as a duplicate of 188087 ***
Comment 4 Jason Baron 2006-06-27 23:21:47 EDT

*** This bug has been marked as a duplicate of 188087 ***
Comment 5 Robin Yamaguchi 2006-06-28 00:46:41 EDT
[root@crosby Desktop]# uname -a
Linux crosby.pcs 2.6.9-39.4.EL #1 Fri Jun 23 17:21:50 EDT 2006 i686 i686 i386 
GNU/Linux
[root@crosby Desktop]# more /etc/redhat-release
Red Hat Enterprise Linux ES release 4 (Nahant Update 3)

Note You need to log in before you can comment on or make changes to this bug.