Bug 196537 - rpm files not copied to resultdir
rpm files not copied to resultdir
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 01:01 EDT by Jim Richardson
Modified: 2013-01-09 20:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-24 17:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the attached patch fixes all version 0.4.8 and later (482 bytes, patch)
2006-06-24 01:01 EDT, Jim Richardson
no flags Details | Diff

  None (edit)
Description Jim Richardson 2006-06-24 01:01:51 EDT
Description of problem: when building a package with mock and specifying the
output directory via --resultdir the src.rpm is copied to the result directory
but not the rpm files.


Version-Release number of selected component (if applicable):
0.4.8 and later

How reproducible: always


Steps to Reproduce:
1. build a package with mock --resultdir defaultresult/packagename
2. logs and src.rpm are in the resultdir but not rpm files
3.
  
Actual results: 

rpm files aren't coped because of a bad glob value in the mock script.



Expected results:
expected the rpm files to be copied to the result directory too

Additional info:
Comment 1 Jim Richardson 2006-06-24 01:01:51 EDT
Created attachment 131478 [details]
the attached patch fixes all version 0.4.8 and later
Comment 2 Jesse Keating 2006-06-24 10:15:41 EDT
Can you retry this with 0.6-4?  Upstream mock released 0.6 a week or 2 ago, and
I finally got a package that works right built yesterday.
Comment 3 Jim Richardson 2006-06-24 12:35:25 EDT
The latest upstream version I can find is mock-0.6.3, and yes the but still
exists there. As a matter of fact upgrading to these latest version broke my
mock and I had research all over again to find my previous patch that I forgot
to report at the time.

If you peek at the patch you'll see the one-liner is really a "no-brainer", a I
suppose the fact that I am not using mock in "extras" and wrote a collection
script to deal with results is the reason this bug hasn't been reported by others.
Comment 4 Jim Richardson 2006-06-24 14:21:22 EDT
I guess I need to revoke my previous comment. After cleaning a build root, the
newly initialized buildroot did solve the problem albeit in a manner which
causes my fix to fail.

Therefore, at this time I do beleive this issue can be closed with a status of
"NOT A BUG"

Note You need to log in before you can comment on or make changes to this bug.