Bug 19654 - LILO reports misleading error when /boot/message has size 0
Summary: LILO reports misleading error when /boot/message has size 0
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lilo   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-24 00:37 UTC by Pierre F. Maldague
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-29 19:14:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pierre F. Maldague 2000-10-24 00:37:32 UTC
Although LILO worked just fine when I installed RH 7.0 out of the box, I
upgraded LILO on another machine (running RH 6.2) to the same version as RH
7.0. It is on this other machine that I noticed the problem.

The problem is that if you don't have a file called 'message' in the /boot
directory (as would be expected when you ipgrade LILO) AND you
inadvertently create a file named /boot/message with nothing in it (e. g.
using 'touch', which I did), then any attempt to run LILO will give you an
"Empty Image" error message.

This is very frustrating because it says nothing about where the error is
coming from. I tracked down the error in the source and it seems to come
from the file that actually writes to the boot sector when it notices that
a block to be written has size 0.

The obvious fix would be to have the calling program notice that the
message file is empty (not the same as a message file containing the single
character '\0') and refrain from writing the block in question.

Comment 1 Chris Abbey 2001-06-29 19:14:04 UTC
equally irritating is this self contradicting output seen on 7.1 and caused by 
a typo in the default= line which rendered it invalid (i.e. not pointing to a 
valid image):

[root@chesire /boot]# lilo
Added linux-243-12smp
Added linux-242-2smp
Added linux-242-2
Added win2k
Fatal: No images have been defined.



Comment 2 Jeremy Katz 2002-06-04 05:23:02 UTC
Not going to fix these as we've switched to grub as our default bootloader only
leaving lilo as a fallback for a few cases that grub doesn't work as well with yet


Note You need to log in before you can comment on or make changes to this bug.