Bug 196554 - User cannot change cpufreq governor in gnome-applet
User cannot change cpufreq governor in gnome-applet
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-06-24 13:11 EDT by Paul Vriens
Modified: 2008-03-18 14:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (682 bytes, patch)
2006-06-24 18:36 EDT, Philippe Troin
no flags Details | Diff

  None (edit)
Description Paul Vriens 2006-06-24 13:11:17 EDT
Description of problem:

On an up-to-date system (June-24-2006) I can no longer, as a user, change the
governor. When looking at /var/log/secure I can see the line:

userhelper[4935]: running '/usr/sbin/cpufreq-selector -g 8t�' with root
privileges on behalf of 'paul'

Version-Release number of selected component (if applicable):

The 'About' shows 2.14.2

How reproducible:

Every time.

Steps to Reproduce:
1. Log in (Gnome) as an ordinary user on a system that support cpufreq
2. try to change the governor via the 'CPU Frequency Scaling Monitor' utility.
3.
  
Actual results:

Nothing changes. The /var/log/secure shows:

userhelper[4935]: running '/usr/sbin/cpufreq-selector -g 8t�' with root
privileges on behalf of 'paul'

every time it's tried.

Expected results:

Change of the governor.

Additional info:

I've seen this already for a few weeks. The latest update probably did it (when
looking at the submit list I can see a change in calling
/usr/sbin/cpufreq-selector).
Comment 1 Philippe Troin 2006-06-24 18:36:52 EDT
Created attachment 131488 [details]
Patch

This patch fixes the problem.
Actually, this feature has been broken by the
gnome-applets-2.14.2-cpufreq.patch patch, so I think this patch should be
merged into gnome-applets-2.14.2-cpufreq.patch.
Comment 2 Henrik Nordstrom 2006-07-25 14:35:21 EDT
Same problem confirmed here.

More details on how to reproduce:

2) Add the cpufreq applet if not active already

3) Right-click ->  Settings -> Menu:  Frequencies and govenors
Close

4) Left-click -> govenors -> ...  nothing happens


tail /var/log/secure, garbage logged where it should show the govenor.


Manually executing /usr/bin/cpufreq-selector with the expected arguments works.

the patch looks sane to me, but haven't tried it (too small problem for me for
doing a gnome-applets rebuild..)
Comment 3 Marcus Brubaker 2006-08-24 16:11:39 EDT
Just wanted to say that I'm seeing this too.  It looks like that patch should
fix things as cpufreq-selector works fine from the command line, but is being
fed garbage by cpufreq-applet.
Comment 4 Marcus Brubaker 2006-08-24 16:32:09 EDT
I can confirm that the patch Works For Me (tm).  Any chance of getting this out
in an update sometime soon?

There doesn't appear to be a a 2.14.4 release on the GNOME horizon so a 2.14.3-2
release of this would be much appreciated by laptop users.
Comment 5 Matthias Clasen 2006-08-27 18:03:16 EDT
I've pushed gnome-applets-2.14.3-2.fc5 into updates-testing, which should fix
this issue.
Comment 6 Matthias Clasen 2006-08-28 13:00:27 EDT
This is an FC5 issue, removing from FC6Target
Comment 7 Fedora Update System 2006-08-28 13:21:24 EDT
gnome-applets-2.14.3-2.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Fedora Update System 2006-09-04 13:16:36 EDT
gnome-applets-2.14.3-2.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 9 Paul Vriens 2006-09-05 04:05:21 EDT
I'm running gnome-applets-2.14.3-2.fc5 now and the issue is solved.

Thanks and regards,

Paul.
Comment 10 Philippe Troin 2006-09-05 19:17:56 EDT
Fixed by gnome-applets-2.14.3-2.fc5.
Comment 11 Henrik Nordstrom 2006-10-02 19:55:12 EDT
Confirmed fixed.
Comment 12 Ray Strode [halfline] 2008-03-18 14:33:51 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.