Bug 1965602 - python-pycares: FTBFS in Fedora rawhide
Summary: python-pycares: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pycares
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthieu Saulnier
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1969086 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1959342 1968884
TreeView+ depends on / blocked
 
Reported: 2021-05-28 11:45 UTC by Tomáš Hrnčiar
Modified: 2021-06-09 21:42 UTC (History)
4 users (show)

Fixed In Version: python-pycares-4.0.0-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-09 21:39:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-05-28 11:45:49 UTC
Description of problem:
Package python-pycares fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
3.2.0-1.fc35

Steps to Reproduce:
koji build --scratch f35 python-pycares-3.2.0-1.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-pycares

Comment 1 Miro Hrončok 2021-06-04 20:12:56 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 22:57:53 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:30:15 UTC
*** Bug 1969086 has been marked as a duplicate of this bug. ***

Comment 4 Ben Beasley 2021-06-09 21:08:28 UTC
PR to fix: https://src.fedoraproject.org/rpms/python-pycares/pull-request/1

Comment 5 Fedora Update System 2021-06-09 21:36:38 UTC
FEDORA-2021-1b50364303 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1b50364303

Comment 6 Fedora Update System 2021-06-09 21:39:13 UTC
FEDORA-2021-1b50364303 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Matthieu Saulnier 2021-06-09 21:42:02 UTC
Thank you Ben Beasley for the fix.


Note You need to log in before you can comment on or make changes to this bug.