Bug 196562 - Improper prerequisites when spec file has 'juk' set to '1'
Improper prerequisites when spec file has 'juk' set to '1'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 16:31 EDT by Joseph D. Wagner
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 08:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patched SPEC file. (775 bytes, patch)
2006-06-24 16:31 EDT, Joseph D. Wagner
no flags Details | Diff

  None (edit)
Description Joseph D. Wagner 2006-06-24 16:31:47 EDT
Description of problem:
SPEC file fails to properly set 'Requires' and 'BuildRequires' prerequisites 
when 'juk' is set to '1'.

Version-Release number of selected component (if applicable):
kdemultimedia-3.5.3-0.1.fc5.src.rpm

How reproducible:
Always

Steps to Reproduce:
Simply set 'juk' to '1' and build the package without libmusicbrainz-devel, 
libtunepimp-devel, and taglib-devel installed.
  
Actual results:
Build of juk fails silently.  In other words, the package still builds, but 
without juk, even though 'juk' was set to '1' in the spec file.


Expected results:
The package should have build with juk.

Additional info:
I also corrected a problem when 'build_mpeg' is set to '1'.
Comment 1 Joseph D. Wagner 2006-06-24 16:31:47 EDT
Created attachment 131486 [details]
Patched SPEC file.
Comment 2 Rex Dieter 2006-06-25 19:16:05 EDT
Not much point to this since juk is now included in kdemultimedia-extras (in
Fedora Extras), and mpeg bits being included in kdemultimedia-extras-nonfree
(rpm.livna.org).

Besides, the Requires: lines are all superfluous.  (:
Comment 3 Ngo Than 2006-06-26 08:35:10 EDT
i gree with Rex here. The lines will be removed in next rebuild.
If someone would like to have  extras stuff, just install from extras or 
rpm.livna.org. Thanks

Note You need to log in before you can comment on or make changes to this bug.