Bug 196587 - pam_setcred changes in kcheckpass from #191049
Summary: pam_setcred changes in kcheckpass from #191049
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-25 13:08 UTC by Kostas Georgiou
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-23 15:25:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kostas Georgiou 2006-06-25 13:08:52 UTC
It seems that kcheckpass now tries pam_setcred with PAM_REFRESH_CRED instead of
PAM_ESTABLISH_CRED which isn't a bad idea. But unfortunately if the renewal time
of your kerberos ticket has expired it will not grab a new ticket for you. I
don't know enough about pam but it would be nice (if pam_setcred returns an
error) to detect this and retry with PAM_ESTABLISH_CRED so the user always has a
valid ticket.

Unfortunately #191049 is closed so I have no idea what the reasoning behind the
change is.

Comment 1 Rex Dieter 2006-08-23 14:31:23 UTC
> Unfortunately #191049 is closed 
puzzling statement since *this* bug is #191049.  (: Did you mean to refer to a
different one?

Comment 2 Kostas Georgiou 2006-08-23 15:25:35 UTC
*This* bug is #196587 :)

In any case this bug seems to be fixed now, I do get new tickets every time I
unlock my screen. I haven't checked what has changed but I can login to my
desktop every morning (since my home is nfs4 with kerberos, I do notice right
away if I don't have a ticket.)


Note You need to log in before you can comment on or make changes to this bug.