Bug 1965975 - libreoffice: FTBFS in Fedora rawhide
Summary: libreoffice: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Stephan Bergmann
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1965974 (view as bug list)
Depends On:
Blocks: F35FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-05-31 09:52 UTC by Tomáš Hrnčiar
Modified: 2021-06-01 07:54 UTC (History)
7 users (show)

Fixed In Version: libreoffice-7.1.3.2-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-01 04:15:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-05-31 09:52:16 UTC
Description of problem:
Package libreoffice fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
7.1.3.2-1.fc35

Steps to Reproduce:
koji build --scratch f35 libreoffice-7.1.3.2-1.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/libreoffice

Comment 1 Miro Hrončok 2021-05-31 11:06:32 UTC
We planned to do the Python 3.10 rebuild this week and without a successful libreoffice build, we cannot merge the side tag if we want to avoid a broken compose.

Hence, marking as urgent. Please have a look at this as soon as possible, ideally this week.

Looks like the build failure is broken by hamcrest that was upgraded from version 1 to version 2: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/EIU7CNABRKL5EFZNCFIWQIK2AHIEKWBB/

Comment 2 Caolan McNamara 2021-05-31 12:11:10 UTC
*** Bug 1965974 has been marked as a duplicate of this bug. ***

Comment 3 Orion Poplawski 2021-05-31 18:50:45 UTC
The naive thing to try is to point to the new jar location: --with-hamcrest=%{_javadir}/hamcrest/hamcrest.jar

Hopefully there aren't any other API incompatibilities.

Comment 4 Stephan Bergmann 2021-05-31 19:56:07 UTC
(In reply to Orion Poplawski from comment #3)
> The naive thing to try is to point to the new jar location:
> --with-hamcrest=%{_javadir}/hamcrest/hamcrest.jar

ah, right, that would have been even easier than <https://src.fedoraproject.org/rpms/libreoffice/blob/71a4281675c2ce631083448149f00969deae55d4/f/0001-Adapt-to-hamcrest-2.2-3.fc35.noarch.rpm.patch>

> Hopefully there aren't any other API incompatibilities.

looks like that was the only issue indeed

Comment 5 Orion Poplawski 2021-05-31 20:29:33 UTC
Well, your patch is probably more flexible at handling different situations so it's all good :)

Comment 6 Fedora Update System 2021-06-01 04:05:27 UTC
FEDORA-2021-2a9891e7b5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-2a9891e7b5

Comment 7 Fedora Update System 2021-06-01 04:15:51 UTC
FEDORA-2021-2a9891e7b5 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Miro Hrončok 2021-06-01 07:54:39 UTC
Thanks for the super fast fix!


Note You need to log in before you can comment on or make changes to this bug.