Bug 1965978 - py4j: FTBFS in Fedora rawhide
Summary: py4j: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: py4j
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1968864 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-05-31 09:57 UTC by Tomáš Hrnčiar
Modified: 2021-06-16 16:21 UTC (History)
3 users (show)

Fixed In Version: py4j-0.10.9-7.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-16 16:21:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-05-31 09:57:05 UTC
Description of problem:
Package py4j fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.10.9-6.fc34

Steps to Reproduce:
koji build --scratch f35 py4j-0.10.9-6.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/py4j

Comment 1 Miro Hrončok 2021-06-04 20:15:23 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 22:59:50 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:19:41 UTC
*** Bug 1968864 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-06-15 20:28:46 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Raphael Groner 2021-06-16 15:25:38 UTC
There's a test failure with hamcrest or openjdk. Nothing obviously related with Python 3.10 so far.

According to koschei: 
hamcrest 2.2-3.fc35 → 2.2-4.fc35
java-11-openjdk-headless 1:11.0.11.0.9-3.fc35 → 1:11.0.11.0.9-4.fc35
etc.

Relevant snippet from build.log follows.

java-test:
    [junit] Testsuite: py4j.BufferGatewayTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.005 sec
    [junit] 
    [junit] Testcase: initializationError(py4j.BufferGatewayTest):	Caused an ERROR
    [junit] org/hamcrest/SelfDescribing
    [junit] java.lang.NoClassDefFoundError: org/hamcrest/SelfDescribing
    [junit] 	at java.base/java.lang.ClassLoader.defineClass1(Native Method)
    [junit] 	at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1017)
    [junit] 	at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174)
    [junit] 	at java.base/jdk.internal.loader.BuiltinClassLoader.defineClass(BuiltinClassLoader.java:800)
    [junit] 	at java.base/jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(BuiltinClassLoader.java:698)
    [junit] 	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(BuiltinClassLoader.java:621)
    [junit] 	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:579)
    [junit] 	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
    [junit] 	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
    [junit] 	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    [junit] 	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    [junit] 	at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    [junit] 	at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:490)
    [junit] Caused by: java.lang.ClassNotFoundException: org.hamcrest.SelfDescribing
    [junit] 	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
    [junit] 	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
    [junit] 	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)

Comment 6 Mikolaj Izdebski 2021-06-16 16:01:56 UTC
Pull request: https://src.fedoraproject.org/rpms/py4j/pull-request/4


Note You need to log in before you can comment on or make changes to this bug.