Bug 196612 - grip cannot ejects audio CDs
grip cannot ejects audio CDs
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-25 19:48 EDT by Dan Christian
Modified: 2009-05-30 07:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-03 08:32:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Christian 2006-06-25 19:48:51 EDT
Description of problem:
grip cannot eject.

Version-Release number of selected component (if applicable):
grip-3.2.0-12.fc5

How reproducible:
Every time

Steps to Reproduce:
1.start grip
2.insert audio CD
3.Press grip's eject button
  
Actual results:
Track display clears and then re-displays, but disk is not ejected.

Expected results:
CD should eject.

Additional info:
auto eject at the end of ripping doesn't work either.

Sometimes I can get a data CD to eject, but not always.

Once grip exits, typing eject will eject the CD.
Comment 1 Adrian Reber 2006-07-14 08:32:34 EDT
Is this on x86_64 only. Because I cannot reproduce it on i386 and I have not
heard from anything likes this anywhere else.
Comment 2 Andreas M. Kirchwitz 2006-07-14 10:58:38 EDT
I have the same problem on a standard i386 platform
(different machines, different CD/DVD drives).
It might be related to the audio CD itself, because
it usually happens if the CD has additional media
tracks (like a data section for computers or video
tracks). 
Comment 3 Dan Christian 2006-07-25 22:47:36 EDT
I finally have a 32 bit system to try it on.  It happens the same there. 
Different brand of DVD drive, too.

These are plain audio CDs.  They aren't mounted.  There are no problems ejecting
once grip exits.  

I'm running kernel 2.6.17-2157.  I don't know if the 64bit system is the exact
same kernel, but it's definitely 2.4.17.

This works for me: ( grip; sleep 1; eject )

If autorip on insert is selected, it will start ripping tracks again.
Comment 4 Adrian Reber 2006-08-07 05:18:57 EDT
I was now able to verify it. Most of the times the CD is not ejected. Sometimes
the CD actually is ejected but this does not happen very often. Unfortunately I
have no idea what the problem is and have not found anything on the grip
mailinglists about this problem.
Comment 5 Dan Christian 2006-09-09 13:03:25 EDT
I switched to an external USB drive (NEC).  That works perfectly.

I'm guessing that this is really a kernel IDE driver problem.
Comment 6 Adrian Reber 2007-07-23 05:15:39 EDT
I have found a solution for this problem. If use the eject routine from libcdio
it works every time but only if I have the newest version of libcdio installed.

As soon the newest libcdio is available for fedora I will release a new version
of grip.
Comment 7 Adrian Reber 2007-09-03 08:32:31 EDT
During further investigation I discovered that this cannot be fixed in grip. The
problem is that hal polls on the CD drive. The only solution for this problem is
to disable hal polling by doing something like this: hal-disable-polling
--device /dev/scd0

Closing it now with CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.