Bug 196614 - PC speaker not working
PC speaker not working
Status: CLOSED DUPLICATE of bug 160172
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-25 20:18 EDT by Florin Andrei
Modified: 2014-03-16 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 00:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2006-06-25 20:18:12 EDT
Description of problem:
The PC speaker is not working. As a result, many applications behave abnormally,
failing to send certain feed-back cues to the user (gnome-terminal, xchat, gaim,
gdm, etc.).

Version-Release number of selected component (if applicable):
initscripts-8.35-1

How reproducible:
always

Steps to Reproduce:
1. install fedora
2. use xchat, or gaim, or anything that runs in any text terminal
3. do anything that triggers the PC speaker
  
Actual results:
PC speaker is silent

Expected results:
PC speaker should beep

Additional info:
The bug can be fixed manually by creating the
/etc/sysconfig/modules/pcspkr.modules executable with the content:

#!/bin/sh
/sbin/modprobe pcspkr

What the distro should do:
Either load the pcspkr module through some kind of system script, or compile it
in the kernel (in which case this becomes a kernel bug).

Please fix this bug, Fedora is unique among Linux distributions (and indeed
among all operating systems) for failing to use a working PC speaker. Many
applications that depend on that are affected.
Comment 1 Bill Nottingham 2006-06-29 00:44:19 EDT

*** This bug has been marked as a duplicate of 160172 ***

Note You need to log in before you can comment on or make changes to this bug.