Bug 196659 - bus error happens with memset
bus error happens with memset
Status: CLOSED DUPLICATE of bug 196658
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 06:02 EDT by William Bai
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 10:10:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Bai 2006-06-26 06:02:46 EDT
Description of problem:
    Bus error in memset when used with shmat(hugetlb), memcpy. It's OK on 
x86_64(hugetlb's pagesize 2MB), but wrong on ia64(hugetlb's pagesize 256MB)


How reproducible:


Steps to Reproduce:
    The following program can duplicate the bus error.

#include <stdio.h>
#include <sys/types.h>
#include <sys/shm.h>
 
int main()
{
   int i = 0;
   int shmid[3];
   void *addr[3];
   for (i=0; i<3; i++) {
     shmid[i] = shmget(IPC_PRIVATE, 256*1024*1024ULL,  
SHM_HUGETLB|IPC_CREAT|SHM_R|SHM_W);
     if (shmid[i] < 0) {
         perror("shmget");
         break;
     }
   }
   
   addr[0] = shmat(shmid[0], NULL, SHM_RND | SHM_UNLOCK);
   printf("addr0 is %lx\n", addr[0]);
   addr[1] = shmat(shmid[1], (void *)addr[0]+256 * 1024 *1024ULL, SHM_RND | 
SHM_UNLOCK);
   printf("addr1 is %lx\n", addr[1]);
   memcpy((void *)addr[1], (void *)addr[0], 256*1024*1024ULL);
   addr[2] = shmat(shmid[2], NULL, SHM_RND | SHM_UNLOCK);
   printf("addr2 is %lx\n", addr[2]);
   memset((void *)addr[2], 0, 256*1024*1024ULL);
}
Comment 1 Jason Baron 2006-06-26 10:10:52 EDT

*** This bug has been marked as a duplicate of 196658 ***

Note You need to log in before you can comment on or make changes to this bug.