Bug 19666 - rpm -U crashed with --excludepath
Summary: rpm -U crashed with --excludepath
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 11979 17488 17489 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-24 03:28 UTC by Alexander Kourakos
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 16:04:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Kourakos 2000-10-24 03:28:01 UTC
On my RH7 system I had removed /var/www/cgi-bin and 
/var/www/html that came with apache. So when installing the new 
apache package, I thought to try the following command:

    rpm -Fvh --excludepath /var/www/cgi-bin \
        --excludepath /var/www/html \
        apache-1.3.14-3.i386.rpm apache-devel-1.3.14-3.i386.rpm

However RPM crashed and coredumped (not a comforting thing in 
the middle of an upgrade). Same behavior with the -U flag. I added a 
few v's and it died after:

    D: getting list of mounted filesystems

So it hadn't actually changed anything yet it seems.
Without the --excludepath it worked fine.

Comment 1 Jeff Johnson 2001-01-08 15:26:11 UTC
Yup. --excludepath is broke. Fix shortly.

Comment 2 Jeff Johnson 2001-01-08 15:42:06 UTC
*** Bug 17489 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2001-01-08 15:43:19 UTC
*** Bug 17488 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Johnson 2001-01-08 16:04:46 UTC
*** Bug 11979 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Johnson 2001-01-09 14:53:21 UTC
Boy, this one's been there since rpm-3.0.4. Fixed in rpm-4.0.2-0.19 and
rpm-4.0.1-0.41.


Note You need to log in before you can comment on or make changes to this bug.