Bug 19668 - up2date chokes on unmet dependencies
Summary: up2date chokes on unmet dependencies
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-24 05:38 UTC by Philip Nemec
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 19:49:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:138 high SHIPPED_LIVE New, enhanced Update Agent for Red Hat Linux 6.x, 7.0 available 2000-12-21 05:00:00 UTC
Red Hat Product Errata RHBA-2001:048 normal SHIPPED_LIVE New Update Agent with many fixes and enhanced functionality available 2001-04-12 04:00:00 UTC

Description Philip Nemec 2000-10-24 05:38:30 UTC
I'm running a system with an older version of X (different problem) so
trying to install something that depends on X (like xemacs) should refuse
but instead gives the [incorrect] error:

Could not solve dependency xpm, depended on by ['xpm']

And then quits.  This means restarting, reloading the update list, etc.

Comment 1 Preston Brown 2000-11-28 16:19:31 UTC
dependency handling has been much enhanced in an errata version of update agent
due to arrive this week.

Comment 2 Philip Nemec 2001-03-14 17:20:31 UTC
The Wolverine version (2.3.1-1) is much better, but still exhibits this
problem.   I can't verify if the problem still exists with 2.4.1-1 because of
different bugs with that version.

Here's the text output, but the main problem is in the GUI mode this quits
rather than allowing unselection...

# up2date XConfigurator

[snip]

There was a fatal RPM error.  The message was:
The package kudzu-0.97.6-1 conflicts with: mouseconfig

-----

There are two bugs here:
* the error message doesn't really tell the conflict - in this case
Xconfigurator
* the GUI should not quit but should allow the conflicting rpm to be unselected
(thus keeping all the other selected rpms selected)


Comment 3 Preston Brown 2001-03-28 19:49:29 UTC
not a bug.  Xconfigurator depends on mouseconfig, and added it to the package 
set.  Up2date reported this as such, you snipped out that portion though.  
However, the mouseconfig conflicts with the version of kudzu you have 
installed.  This was beta/rawhide hysteresis that has since been corrected.

The other problem (shouldn't quit if dependency issues are found, but instead 
allow you to reselect packages) has been changed in CVS.


Comment 4 Preston Brown 2001-04-12 20:55:49 UTC
issues addressed in errata due out today.


Note You need to log in before you can comment on or make changes to this bug.