Bug 196682 - /usr/X11R6/lib/libXm.so symlink missing on x86_64
/usr/X11R6/lib/libXm.so symlink missing on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 09:39 EDT by Dmitry Bolkhovityanov
Modified: 2014-03-16 23:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 00:42:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Bolkhovityanov 2006-06-26 09:39:28 EDT
Description of problem:
Lots of 3-rd-party programs specify "-L/usr/X11R6/lib" in their Makefiles in
order to pick up Motif library via "-lXm". Usually the libXm.so->libXm.so.3.0.2
symlink is owned by openmotif-devel*.rpm.

BUT, since there's no openmotif-devel-*.i386.rpm for x86_64, NO PACKAGE creates
/usr/X11R6/lib/libXm.so (yes, /usr/X11R6/lib64/libXm.so does exist).

The right fix would be to add this symlink to regular x86_64's
openmotif-2.2.3-*.i386.rpm.

Version-Release number of selected component (if applicable):
2.2.3-10.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. ls -l /usr/X11R6/lib/libXm.so
  
Actual results:
ls: /usr/X11R6/lib/libXm.so: No such file or directory

Expected results:
lrwxrwxrwx 1 root root           14 Sep 2 2005 /usr/X11R6/lib/libXm.so ->
libXm.so.3.0.2

Additional info:
Since FC5 places Motif libraries into /usr/lib* instead of /usr/X11R6/lib*, it
is probably unaffected -- "-lXm" would pick the library anyway. But FC4's
default behaviour is annoying.
Comment 1 Thomas Woerner 2006-06-26 10:26:12 EDT
The openmotif-devel.i386 package provides this symlink.
Comment 2 Dmitry Bolkhovityanov 2006-06-26 10:38:41 EDT
Yes, the openmotif-devel.i386 DOES provide this link, but there is NO
openmotif-devel.i386 under FC4/x86_64:

.../fedora/4% find . -name 'openmotif*'
./i386/YUM/openmotif-devel-2.2.3-10.i386.rpm
./i386/YUM/openmotif-2.2.3-10.i386.rpm
./i386/YUM/openmotif21-2.1.30-14.i386.rpm
./x86_64/YUM/openmotif21-2.1.30-14.i386.rpm
./x86_64/YUM/openmotif-2.2.3-10.i386.rpm
./x86_64/YUM/openmotif-devel-2.2.3-10.x86_64.rpm
./x86_64/YUM/openmotif-2.2.3-10.x86_64.rpm
./SRPMS/openmotif21-2.1.30-14.src.rpm
./SRPMS/openmotif-2.2.3-10.src.rpm

And attempt to install i386's openmotif-devel.i386 would lead to conflict
between files with openmotif-devel.x86_64.
Comment 3 Roman E. Kuskov 2006-06-26 11:23:16 EDT
openmotif-devel.i386 from FC4 i386 can be installed to solve this problem.
I wonder why there's no distinct package for FC4 x86_64.
Comment 4 Bill Nottingham 2006-06-29 00:42:45 EDT
This will be fixed in FC6. Note that any package trying to build x86_64 binaries
by adding -L/usr/X11R6/lib are just broken, and won't link correctly even with
the i386 openmotif-devel shipped.
Comment 5 Dmitry Bolkhovityanov 2006-06-29 00:51:52 EDT
(In reply to comment #4)
> This will be fixed in FC6. Note that any package trying to build x86_64 binaries
> by adding -L/usr/X11R6/lib are just broken, and won't link correctly even with
> the i386 openmotif-devel shipped.

Yes, that's true. And most Makefiles allow simply passing "CFLAGS=-m32" to
'make', which could fix the problem. But when there's no 32-bit libXm.so,
nothing helps.

And, by the way, absence of openmotif-devel.i386 means that one can't build i386
Motif programs on x86_64 machine, which is just nonsence.
Comment 6 Bill Nottingham 2006-06-29 01:07:47 EDT
Yea, was just wanting to make sure which you're building. For FC4 and FC5 we
only shipped a limited development environment for compat arches (generally, the
LSB set.) For FC6, we're cleaning things up so we can ship a full devel
environment; since this involves some significant cleanup to headers,
<foo>-config scripts, etc., it's a little much to backport to earlier FC releases.

Note You need to log in before you can comment on or make changes to this bug.