Bug 196685 - Logrotate claims that 12-22-2005 is in the future
Logrotate claims that 12-22-2005 is in the future
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 10:23 EDT by Christopher Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 08:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Johnson 2006-06-26 10:23:04 EDT
Description of problem:
The nightly logrotate cron job yields this message:
/etc/cron.daily/logrotate:
error: log /var/account/pacct last rotated in the future -- rotation forced

Version-Release number of selected component (if applicable):
logrotate-3.7.3-2.2.1

How reproducible:
Nightly.

Steps to Reproduce:
1. -rw-r--r-- 1 root root 0 Dec 22  2005 /var/account/pacct
2. psacct installed
3. let logrotate cron job run
  
Actual results:
The above error message.

Expected results:
Probably no message would be appropriate.

Additional info:
My concern is that logrotate considers 12-22-2005 to be in the future when the
system date is clearly after that.  This has been happening since FC5 was
installed several weeks ago.  Today the system date is Mon Jun 26 10:28:04 EDT 2006
Comment 1 Peter Vrabec 2006-06-27 07:40:45 EDT
Could you send output of this:
$ cat /var/lib/logrotate.status | grep pacct
Comment 2 Christopher Johnson 2006-06-27 13:17:44 EDT
"/var/account/pacct" 2006-9-1

Interesting.  So this is the "last rotated" date, and it is in the future.  But
how did it get that way?

# ls /var/log/wtmp
wtmp    wtmp.1
# last -f /var/log/wtmp.1
[snip]
root     pts/0        10.1.250.4       Sun May 14 08:35 - 09:32  (00:57)
root     pts/1        10.1.250.4       Sat May 13 15:53 - 19:18  (03:25)
root     pts/0        10.1.250.4       Sat May 13 12:12 - 19:04  (06:52)
reboot   system boot  2.6.16-1.2111_FC Sat May 13 12:11         (45+01:09)

wtmp.1 begins Sat May 13 11:59:47 2006

Only May and June dates show in any wtmp files.  May is when it was installed.
Comment 3 Peter Vrabec 2006-06-29 08:33:04 EDT
I don't know how it happend. :-(

Note You need to log in before you can comment on or make changes to this bug.