Bug 196698 - missing libreadline.so.4 library in netstg2.img
Summary: missing libreadline.so.4 library in netstg2.img
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted
Version: 4.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 196699 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-26 15:28 UTC by Ivars Strazdins
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-03-05 21:06:30 UTC


Attachments (Terms of Use)

Description Ivars Strazdins 2006-06-26 15:28:42 UTC
Description of problem:

libreadline.so.4 library in netstg2.img image is missing. parted application
cannot be started if system is booted from network.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
Prior boot we had:
1. configured DHCPD (assign IP address and other network parameters)
2. configured TFTP (provides elilo + elilo.conf + vmlinuz +
initrd.img)
3. copied all CDROMs to HTTP server.

While in EFI, issued command "lanboot".
It loads elilo and kernel.
4. Next step is provide information about HTTP server.
Then everything goes exactly as when booting from CDROM.

While examing environment, I found that CDROM rescue boot uses
stage2.img file and mounts it as root (using loop device). Network
boot uses netstg2.img file for the same purpose.

After looking into these files I found, that first one contains
libreadline.so and second no.
  
Actual results:

Run 'linux rescue' after booting 1st CDROM.
Choose 'Skip' when suggested to detect already installed OS.
In shell prompt enter following command:
# parted /dev/sdc
Following error will be shown.
parted: error while loading shared libraries: libreadline.so.4: cannot open
shared object file: No such file or directory

Expected results:

be able to run parted

Additional info:
none

Comment 1 David Cantrell 2007-03-05 21:06:30 UTC
The libreadline.so.4 library is in stage2.img and netstg2.img in RHEL-4 U5.

Comment 2 David Cantrell 2007-03-05 21:07:10 UTC
*** Bug 196699 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.