Bug 19670 - problem installing redhat 7.0 with all packages
problem installing redhat 7.0 with all packages
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 03:27 EDT by hsauer
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 16:14:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hsauer 2000-10-24 03:27:31 EDT
When I try to install RedHat 7.0 with all packages via the Everything
selection
when selecting packages for a user choice installation I get the following
errors after the
partitions are formatted and the installation image is copied to the
Harddrive

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438 in ?
    intf.run (todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply(step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py, line 507, in
__call__
    if todo.doInstall():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInst
all
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selcted
()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py, line 63, in
systemMo
unted
   isys.lochangefd('/tmo/loop", self.loopbackFile)
  File "isys.py", line 55, in lochangefd _isys.lochangefd(loop, targ)
System Error: (22, 'Das Argument ist ungueltig')

I don't get these errors when I choose the Workstation installation.
I'm using a bootdisk from <http://sweb.uky.edu/~mabran3/linux/misc/> to
install the system on my harddrive connected to Promise ATA 100 Controller
on my Asus A7V mainboard.
Comment 1 Michael Fulbright 2000-10-30 16:14:15 EST
This appears to be a problem with the boot disk you are using and the loopback
filesystem we use to allow multi-CD installs.

When you do a workstation install only the first CD is used, and the loopback
filesystem is not a factor.

One a Everything install, the loopback filesystem mechanism is used.

The workaround is to just do Custom install, then pick all the components EXCEPT
Everything.

That will get most of the packages installed, then you can use gnorpm or the rpm
command line to install anything else.

Since this occurs with your custom bootdisk there really is no way to duplicate
the problem here.

Note You need to log in before you can comment on or make changes to this bug.