Bug 196701 - anaconda segv when specifying static ip
anaconda segv when specifying static ip
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: Regression
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-06-26 11:30 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 16:20:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-06-26 11:30:47 EDT
Description of problem:
Seen in the stage1 when anaconda is asking for ip info so that it can do an NFS
install.  I am seeing this on 2 different HP Integrity servers using eth0. 
Going to verify if I see the same on e1000 and tg3 in a bit.

Immediatly after specifying the static ip info I get:


loader received SIGSEGV!.  Backtrace:
[0x40000000000036b0]
[0xa0000000000107e0]
[0x4000000000331e51]
[0x4000000000185a60]
[0x40000000001933a0]
[0x4000000000032dd0]
[0x4000000000032e20]
[0x4000000000034f50]
[0x4000000000005740]
[0x400000000026de10]
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
you may safely reboot your system

Version-Release number of selected component (if applicable):
rawhide-20060626
anaconda-11.1.0.48-1
kernel-2.6.17-1.2307_FC6


How reproducible:
100% on my rx2600 w/e100, will verify on other HP Integrity hardware

Steps to Reproduce:
1. boot the installer for NFS install
2. deselect the "dhcp" option for the network interface
3. enter static ip info
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2006-06-26 12:01:05 EDT
I have tried this on other HP Integrity systems with e1000 and tg3 NIC's with
the same results.  So, likely not hardware specific.

Comment 2 David Cantrell 2006-06-30 13:08:15 EDT
I've worked through this and there don't appear to be anymore sigsegv's, but
what happens now is the loader will exit immediately before launching anaconda.
 Tracking this down.
Comment 3 Doug Chapman 2006-07-05 15:34:43 EDT
FYI, just tried this on the rawhide-20060703/anaconda-11.1.0.51-1 and the
behavior has changed slightly.  Instead of a segv and a traceback I get this
when specifying the ip info manually (works OK if I use dhcp).

install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
you may safely reboot your system
Comment 4 David Cantrell 2006-07-05 15:41:57 EDT
That's a fun one.  *sigh*

Looks like it's back.  I'm trying to figure out what's causing this to happen. 
Got it working on Friday and kicked off the 11.1.0.51 build, which I thought
fixed it.

Are you trying to get it to run the graphical installer or text?  Try text if
you are using graphical mode.  There seem to be other issues with the graphical
installer mode starting at the moment.
Comment 5 Doug Chapman 2006-07-05 16:01:19 EDT
Dave,

All my systems are headless so this was text mode via serial console.  I tried
both with vnc and without and got the same results.

- Doug
Comment 6 David Cantrell 2006-07-17 16:17:31 EDT
Doug,

Can you try with a rawhide tree starting tomorrow?  That should include
anaconda-11.1.0.58.

-David
Comment 7 David Cantrell 2006-07-17 16:20:55 EDT
Disregard last comment.  Closing this bug as 199143 is this issue carried
forward to a more recent rawhide/anaconda.

Note You need to log in before you can comment on or make changes to this bug.