Bug 196732 - Resume from suspend causes X to hang
Resume from suspend causes X to hang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 15:16 EDT by J.H.
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 01:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (3.44 KB, text/plain)
2006-06-27 12:44 EDT, J.H.
no flags Details
Xorg log from a failed resume (56.79 KB, text/plain)
2006-06-27 12:47 EDT, J.H.
no flags Details
Messages log (40.65 KB, application/octet-stream)
2006-06-27 12:58 EDT, J.H.
no flags Details

  None (edit)
Description J.H. 2006-06-26 15:16:37 EDT
Description of problem:
Upon resume from a suspend to ram X does not resume.  The system comes up
without much issue (network comes back up and it's capable of sshing into the
machine and running diagnostics) but X spins off and uses 100% of the CPU. 
Doing an strace on the Xorg process shows that literally nothing is happening
(strace attachs but displays nothing).  Process exsists in Rs+ state accroding
to `ps`.  

Version-Release number of selected component (if applicable):
xorg starting with FC6-test1

How reproducible / Steps to Reproduce:
1) Suspend machine (echo mem > /sys/power/state) - backlight turns off to the
screen but last image on screen still present.
2) Resume machine backlight turns on, machine resumes.
3) Image on screen is still of that just before suspend.
4) Machine is responsive, hitting the power button invokes the proper shutdown
command.  If network is up sshing to the machine is possible.
  
Actual results:
Screen is frozen at the image prior to suspend.

Expected results:
Machine to come up and X to resume.


Additional info:

Only thing of note is that X has been acting odd as well, sometimes freezing
similar to the resume issue when opening apps though it's not as consistent. 
The same problems are there, X is hung, but the system is still alive.  Opening
Firefox (with about 100 tabs), evolution, openoffice and a few other large
programs might trigger the problem but it's not consistent

Hardware information:
IBM T42 w/ ATI 7500 graphics card
2ghz Pentium M
1.5GB RAM
Comment 1 Mike A. Harris 2006-06-27 10:18:56 EDT
This could be an X server problem, a video driver problem, a kernel problem,
or any host of other potential causes.

Please attach your X server log file, config file, /var/log/messages
as individual uncompressed file attachments using the link below.
Comment 2 J.H. 2006-06-27 12:44:02 EDT
Created attachment 131616 [details]
xorg.conf file
Comment 3 J.H. 2006-06-27 12:47:45 EDT
Created attachment 131617 [details]
Xorg log from a failed resume
Comment 4 J.H. 2006-06-27 12:58:19 EDT
Created attachment 131618 [details]
Messages log

Pertinant section of the log file, from a bit before the suspend to a bit
afterwards.  NetworkManager & dhcp messages were stripped because of their
frequency and tendency to clutter the log file
Comment 5 Kevin Fenzi 2007-03-24 00:43:04 EDT
Hey J.H.: 
is this still happening with fc6 and/or current development? 

Note, that you should try 'pm-suspend' instead of just doing the 'echo mem >
/sys/power/state'. pm-suspend knows modules that should be unloaded, and various
other workarounds for issues. 
Comment 6 J.H. 2007-03-24 01:00:39 EDT
I have not seen this particular issue since test1 and I am now running the
2.6.19-1.2911.6.3.fc6 and am not seeing issues (and continuing to do echo mem >
/sys/power/state)  I'm fine with the bug being closed.
Comment 7 Kevin Fenzi 2007-03-24 01:04:02 EDT
ok. Thanks for the prompt reply. 

Note You need to log in before you can comment on or make changes to this bug.