Bug 19674 - Missing and wrong files
Missing and wrong files
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 06:06 EDT by Boris Folgmann
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 06:06:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Folgmann 2000-10-24 06:06:51 EDT
The script /etc/sysconfig/apm-scripts/apmscript which is very important for
apmd has several bugs or your file packaging in the RPMs.

apmscript uses /usr/sbin/cardctl but this is in fact in /sbin.
apmscript uses /usr/sbin/soundon and soundoff which are not on my system
(why?).

I did a symlink so that cardctl could be found by apmscript. 
Because I have problems with my PCMCIA-NIC I use PCMCIARESTART="yes" in
/etc/sysconfig/apmd so that /etc/sysconfig/apm-scripts/apmscript does a
cardctl suspend and resume before and after putting my notebook to suspend
mode. But this doesn't help me with my card problems. After wake-up I get
eth0: transmit timed out from my "Xircom CreditCard 10/100 + Modem 56". So
I tried cardctl eject and insert instead and that works!

Also the setting that should refuse anacron from working when on battery
power does not work! Please check that also!

Please fix all that stuff.

Tnx,

	Boris.
Comment 1 Bernhard Rosenkraenzer 2000-10-24 06:34:47 EDT
The location of cardctl has been fixed for a couple of weeks.

soundon and soundoff are part of the commercial version of the OSS sound drivers, which are unfortunately required by a lot of notebooks at this time.
Don't worry about them, unless you're using the commercial OSS stuff, they aren't supposed to exist (and they aren't executed when they don't exist).

The PCMCIA specs say pcmcia suspend and pcmcia resume should be sufficient, and it actually works for me (Gericom 3xC, noname ne2k compatible PCMCIA card). The problem here is either your BIOS or your PCMCIA controller itself, and pcmcia eject actually ejects the card on some hardware.
I'm adding a new PCMCIABIOSBUG switch to /etc/sysconfig/apmd.

anacron is fixed, too.

(3.0final-23)
Comment 2 Boris Folgmann 2000-10-24 07:07:10 EDT
Tnx, adding PCMCIABIOSBUG is a good idea. I also have problems when my battery
gets empty. The notebook doesn't go automatically to suspend mode. So I lose all
data and I have to reboot with invalids harddisk when power is back again.
I've set up an apmcontine with apm --suspend in the ($1==change && $2==battery)
case, that seems to work. May be you can add a SUSPEND_ON_BATTERYLOW or
something to the sysconfig/ampd file.

I have a Fujitsu Lifebook with Phoenix NoteBIOS 4.0.

Note You need to log in before you can comment on or make changes to this bug.