Bug 19680 - problem using X11 lib on Linux 7.0 RC1 Alpha
Summary: problem using X11 lib on Linux 7.0 RC1 Alpha
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: alpha Linux
high
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-24 13:19 UTC by john.goshdigian
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 14:00:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description john.goshdigian 2000-10-24 13:19:42 UTC
> g++ -o tt t.cxx -L/usr/X11R6/lib -lX11
/usr/bin/ld: warning: type and size of dynamic symbol `__gmon_start__' are 
not defined

> cat t.cxx
void main() { }

Comment 1 Ngo Than 2000-10-24 14:00:10 UTC
Jakub, i think it comes from binutils

Comment 2 Jakub Jelinek 2000-10-24 15:07:25 UTC
Looks like for some reason __gmon_start__ was not undefined in XFree86-libs-4.0.1-0.45,
but it is undefined weak in 4.0.1-1.1 so things are ok.
I've checked all .o stubs provided by glibc and their definition of __gmon_start__
is ok, none of gcc's .o stubs ever mention __gmon_start__.


Note You need to log in before you can comment on or make changes to this bug.