Bug 196802 - 16M memory needs to be set in pear/pecl
16M memory needs to be set in pear/pecl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-pear (Show other bugs)
5
All Linux
high Severity high
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks: php-pear-MDB2 pear-PHPUnit3 php-pear-PHPUnit2 php-pear-Date phpDocumentor
  Show dependency treegraph
 
Reported: 2006-06-26 21:22 EDT by Christopher Stone
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.9-1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 05:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2006-06-26 21:22:47 EDT
Description of problem:
I am trying to package some php-pear and php-pecl packages for Fedora Extras. 
Some of these packages require more than the 8M of memory which is set as
default in the php.ini file.

To resolve this issue, the scripts files /usr/bin/pear and /usr/bin/pecl need to
have a -d memory_limit=16M parameter option included.

I think this should be patched as soon as possible and sent to upstream.  I am
forced to call php directly myself to run pearcmd.php/peclcmd.php in the meantime.

Version-Release number of selected component (if applicable):
1.4.9-1
Comment 1 Joe Orton 2006-07-03 08:06:06 EDT
I've submitted 1.4.9-1.1 to updates-testing - can you test this out when it gets
pushed?
Comment 2 Christopher Stone 2006-07-07 18:54:23 EDT
I tested this out and it works perfectly.
Comment 3 Jason Tibbitts 2006-08-14 21:53:37 EDT
Is there any chance that this (well, actually the newer 1.4.9-1.2 that's
currently in updates-testing) could be pushed to updates in the near future?
Comment 4 Christopher Stone 2006-08-21 15:58:23 EDT
Hi Joe, thanks for all your help with this bug and the new pear/pecl macros bug.
 I have tested them out on testing and both patches work great.   We *really*
need this stuff in FC5 updates now so that we can progress with doing reviews
with php.  We have about 10+ or so packages that are blocked up on the macros
right now, and we urgently need this new package in FC5 so we can progress forward.

I am upping the priority on this.  Can you add this new version to updates
sometime this week?  Thanks again!
Comment 5 Christopher Stone 2006-08-29 12:17:16 EDT
Bumping priority up to high.  What is it going to take to add this to FC5?  Can
we get someone to check this is as Joe seems AWOl.
Comment 6 Jason Tibbitts 2006-08-30 01:46:15 EDT
Looks like the updated package hit the mirrors today, so we should be able to
move forward with pretty much all of those PHP packages.
Comment 7 Joe Orton 2006-08-30 05:06:51 EDT
Sorry for the delay getting this shipped.  Thanks for supplying the macros!

Note You need to log in before you can comment on or make changes to this bug.