Bug 196885 - Bug in rhgb-modularx.patch means rhgb doesn't use custom xorg.conf
Bug in rhgb-modularx.patch means rhgb doesn't use custom xorg.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 10:45 EDT by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 12:10:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2006-06-27 10:45:19 EDT
Description of problem:
It's intended that you should be able to specify a different xorg.conf for rhgb
than for X as a whole. However, the patch "rhgb-modularx.patch" (which was
probably added in January) contains the following lines, among others:

-#define X_CONFIG "/etc/rhgb/xorg.conf"
-#define XLOGFILE TMPPATH"/XFree86.0.log"
+#define X_CONFIG "/etc/rhgb/xorg .conf"
+#define XLOGFILE TMPPATH"/xorg.log"

So it's looking for a config file "xorg .conf" with a space, which is probably
wrong.

Version-Release number of selected component (if applicable):
rhgb-0.16.3-1.fc5.1

How reproducible:
Always

Steps to Reproduce:
1. Create custom /etc/rhgb/xorg.conf
  
Actual results:
rhgb still uses default xorg.conf

Expected results:
rhgb should use the new one!
Comment 1 Ray Strode [halfline] 2006-07-05 12:10:54 EDT
Hi,

Thanks for spotting this.  It should be fixed in tomorrow's rawhide.

Note You need to log in before you can comment on or make changes to this bug.