Bug 1968960 - F35FailsToInstall: drgn
Summary: F35FailsToInstall: drgn
Keywords:
Status: CLOSED DUPLICATE of bug 1948977
Alias: None
Product: Fedora
Classification: Fedora
Component: python-drgn
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Davide Cavalca
QA Contact:
URL:
Whiteboard:
Depends On: 1968365
Blocks: F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-06-07 23:38 UTC by Miro Hrončok
Modified: 2021-06-08 11:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-08 11:24:28 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-07 23:38:04 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-drgn) Fails To Install in Fedora 35:

can't install drgn:
  - nothing provides python3.9dist(setuptools) needed by drgn-0.0.11-2.fc35.x86_64
  - nothing provides python(abi) = 3.9 needed by drgn-0.0.11-2.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Davide Cavalca 2021-06-07 23:40:32 UTC
The new version will fix this.

Comment 2 Miro Hrončok 2021-06-07 23:44:01 UTC
This bugzilla is likely a fallout from the Python 3.10 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.10 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.10, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 3 Miro Hrončok 2021-06-08 11:24:28 UTC
Automatically marking as duplicate. Please forgive me if not accurate.

*** This bug has been marked as a duplicate of bug 1948977 ***


Note You need to log in before you can comment on or make changes to this bug.