Bug 1968986 - F35FailsToInstall: python3-gast: Fails to build with Python 3.10: TypeError: required field "lineno" missing from alias
Summary: F35FailsToInstall: python3-gast: Fails to build with Python 3.10: TypeError: ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-gast
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1958947 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1927172 1968909 1969180
TreeView+ depends on / blocked
 
Reported: 2021-06-07 23:39 UTC by Miro Hrončok
Modified: 2021-06-28 20:43 UTC (History)
3 users (show)

Fixed In Version: python-gast-0.5.0-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-28 20:43:45 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github serge-sans-paille gast issues 56 0 None open Python 3.10: TypeError: required field "lineno" missing from alias 2021-06-21 08:41:12 UTC

Description Miro Hrončok 2021-06-07 23:39:30 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (python-gast) Fails To Install in Fedora 35:

can't install python3-gast:
  - nothing provides python(abi) = 3.9 needed by python3-gast-0.4.0-2.fc34.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-07 23:45:31 UTC
This bugzilla is likely a fallout from the Python 3.10 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.10 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.10, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Petr Viktorin 2021-06-08 09:38:35 UTC
*** Bug 1958947 has been marked as a duplicate of this bug. ***

Comment 3 Miro Hrončok 2021-06-21 08:41:14 UTC
I've reported this to upstream: https://github.com/serge-sans-paille/gast/issues/56

Comment 4 Fedora Update System 2021-06-28 20:42:06 UTC
FEDORA-2021-e86267bc0f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-e86267bc0f

Comment 5 Fedora Update System 2021-06-28 20:43:45 UTC
FEDORA-2021-e86267bc0f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.