Bug 196899 - qt4: split-out gui(x11) from non-gui bits
Summary: qt4: split-out gui(x11) from non-gui bits
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt4   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-27 15:45 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 14:45:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2006-06-27 15:45:29 UTC
Since qt4 separated much of it's functionality into separate shared libs, it is
now possible to create console (ie, non-gui/x11) qt4 apps.  In this case,
installing the existing qt4 pkgs with it's dependancies on xorg-x11 would be
largely wastefull.

For example, SuSE has a qt(4)-x11 subpkg.

Comment 1 Rex Dieter 2006-06-27 18:22:08 UTC
So, what to name the "gui" bits... qt4-x11, qt4-gui?
Atm, I'm leaning toward qt4-gui

Comment 2 Rex Dieter 2006-06-28 17:38:37 UTC
Turns out most other pkgs use -x11 for this, -gui usually implies an gui *app*.

Comment 3 Rex Dieter 2006-06-29 14:45:48 UTC
* Wed Jun 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1.4-4
- x11: split-out gui(x11) from non-gui bits (bug #196899)


Note You need to log in before you can comment on or make changes to this bug.