Bug 19690 - libpcap-0.4-29.i386.rpm seems to be broken
libpcap-0.4-29.i386.rpm seems to be broken
Status: CLOSED DUPLICATE of bug 6773
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 11:21 EDT by Nadav Har'El
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-25 12:33:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadav Har'El 2000-10-24 11:21:20 EDT
Is something wrong with libpcap-0.4-29.i386.rpm?

I wanted to use the "sting" packet-loss measurement tool from
    http://www.cs.washington.edu/homes/savage/sting/
This tool uses libpcap, and should work on Linux (the author said it does).
Anyway, using /usr/lib/libpcap.a it didn't work (from the little debugging 
I did, it appears as if pcap_next does not timeout correctly, and just gets
stuck). When I compiled libpcap-0.4 (which is also available in sting's
tar)
myself (easy - just did configure and make) and used the resulting library,
sting worked perfectly.

Could it be that something is wrong in the way libpcap-0.4 is compiled, or
something? I know from (bad) experience that static libraries compiled in
previous versions of gcc (e.g., on Redhat 6.2) no longer work correctly on
Redhat 7, giving seemingly random and hard-to-detect lockups and errors. 
Using objdump -x on this library says that it was compiled on Aug 12 - that
is way before Redhat 7 was released, so maybe you just forgot to recompile
it for the new gcc?
Comment 1 Jeff Johnson 2000-10-25 12:33:53 EDT
Linux uses a different libpcap than you are expecting. See details at bugzilla
#6773 et al.
Comment 2 Jeff Johnson 2000-10-25 12:34:29 EDT

*** This bug has been marked as a duplicate of 6773 ***

Note You need to log in before you can comment on or make changes to this bug.