Bug 1969181 - F35FailsToInstall: qemu-system-x86-core
Summary: F35FailsToInstall: qemu-system-x86-core
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F35FailsToInstall 1968825
TreeView+ depends on / blocked
 
Reported: 2021-06-07 23:50 UTC by Miro Hrončok
Modified: 2021-06-09 16:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-09 15:22:18 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-07 23:50:11 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (qemu) Fails To Install in Fedora 35:

can't install qemu-system-x86-core:
  - nothing provides libxenctrl.so.4.14()(64bit) needed by qemu-system-x86-core-2:6.0.0-1.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Kevin Fenzi 2021-06-07 23:53:31 UTC
So, this seems to have happened because:

4.15.0 was built in a side-tag: 

Thu May  6 13:11:52 2021 xen-4.15.0-1.fc35 tagged into f35-build-side-40901 by myoung

but never merged. 

Then the python 3.10 rebuild came along and rebuilt that 4.15.0 version... 

So, qemu just needs a rebuild against xen-4.15.0-2.fc35.

Comment 2 Richard W.M. Jones 2021-06-08 09:34:53 UTC
Looks like Cole initiated a build last night:

https://koji.fedoraproject.org/koji/taskinfo?taskID=69546172

It was built against python3.10 3.10.0~b2-3.fc35 which is the latest
python3.10 package in Koji (https://koji.fedoraproject.org/koji/packageinfo?packageID=32438)

It failed on s390x, but is still running on Power (I also noticed that the
Power builders were really slow yesterday).

Anyway my intuition is to let Cole deal with this.

Comment 3 Cole Robinson 2021-06-08 14:50:59 UTC
s390x tests have been failing randomly for a week, Dan Horak couldn't reproduce outside of koji though.

Not sure what the ppc64le issue is all about but it seems to have hung in the test suite. I'm trying a build now with the tests disabled

Comment 4 Cole Robinson 2021-06-08 17:22:29 UTC
Fixed in qemu-6.0.0-5.fc35

Comment 5 Miro Hrončok 2021-06-08 17:36:55 UTC
qemu-6.0.0-5.fc35 build was canceled.

Comment 6 Richard W.M. Jones 2021-06-09 12:56:33 UTC
I pushed a small fix to the previous work which will *hopefully*
fix the package on s390x and ppc64le:

qemu-6.0.0-5.fc35
https://koji.fedoraproject.org/koji/taskinfo?taskID=69694841

Comment 7 Richard W.M. Jones 2021-06-09 15:22:18 UTC
Well it built, so hopefully it's all good now.

Comment 8 Cole Robinson 2021-06-09 16:01:48 UTC
Sorry for the confusion, thanks for fixing it Rich. I had fixed the breakage locally and submitted a scratch build to confirm it worked. By the time the build finished I forgot it was a scratch build and thought it was a regular `fedpkg build` and added the comment here :)


Note You need to log in before you can comment on or make changes to this bug.