Bug 1969198 - F35FailsToInstall: veusz
Summary: F35FailsToInstall: veusz
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: veusz
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeremy Sanders
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1972943 (view as bug list)
Depends On: 1936839
Blocks: F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-06-07 23:50 UTC by Miro Hrončok
Modified: 2021-06-16 23:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-16 19:34:12 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-07 23:50:56 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (veusz) Fails To Install in Fedora 35:

can't install veusz:
  - nothing provides python3.9dist(setuptools) needed by veusz-3.3.1-2.fc34.x86_64
  - nothing provides python3.9dist(numpy) needed by veusz-3.3.1-2.fc34.x86_64
  - nothing provides python3.9dist(pyqt5) needed by veusz-3.3.1-2.fc34.x86_64
  - nothing provides python(abi) = 3.9 needed by veusz-3.3.1-2.fc34.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-07 23:55:06 UTC
This bugzilla is likely a fallout from the Python 3.10 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.10 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.10, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Miro Hrončok 2021-06-15 20:53:59 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Jeremy Sanders 2021-06-16 19:34:12 UTC
I've rebuilt veusz without the python3-astropy build dependency, which doesn't yet build under Python 3.10. The dependency can still be used at runtime if fixed (it is used for tests). I'll put it back if it gets built for Python 3.10.

Comment 4 Miro Hrončok 2021-06-16 23:54:50 UTC
*** Bug 1972943 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.