Bug 196923 - 60-wacom.rules is not applied, thus no /dev/input/wacom symlink
60-wacom.rules is not applied, thus no /dev/input/wacom symlink
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aristeu Rozanski
:
: 163603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 13:19 EDT by A. Lok
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-19 15:42:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Lok 2006-06-27 13:19:06 EDT
Description of problem:

The /dev/input/wacom symlink is not created. It seems that the udev-rule
/etc/udev/rules.d/60-wacom.rules isn't processed at all. When renamed to
10-wacom.rules (like in fc5) and unplugging and replugging the the wacom
usb-device does create the symlink and gives the following message in
/var/log/messages:
Jun 27 19:15:11 sharptooth udevd-event[3043]: find_free_number: %e is
deprecated, will be removed and is unlikely to work correctly. Don't use it.

I don't exactly know why the 60-wacom.rules is not processed.

Version-Release number of selected component (if applicable):
linuxwacom-0.7.4_1-2

How reproducible:


Steps to Reproduce:
1. Start fedora core 6 tst 1
  
Actual results:
no symlink /dev/input/wacom

Expected results:
a symlink /dev/input/wacom to the appropriate device
Comment 1 A. Lok 2006-08-10 16:19:05 EDT
Updated to Fedora Core 6 test 2.

I figured out that the 60-wacom.rules isn't applied because 50-udev.rules
hijacks every input* 
line 175:
KERNEL=="event*",		NAME="input/%k"

Commenting this line out, and unplugging and inserting the usb-tablet again,
does create the wanted wacom link. It somehow needs to exclude the wacom tablet,
or put the wacom rule before the general-rule?.
Comment 2 Georgiy Shapovalov 2006-09-28 00:22:18 EDT
(In reply to comment #1)
>...
> or put the wacom rule before the general-rule?.

For me it works by renamig 60-wacom.rules to 49-wacom.rules
It seems loading order is important for rules... in that case 50-udev.rules will
not hijack wacom's input since it will be loaded after 49-wacom.rules and gets
lower precedence.
Comment 3 A. Lok 2006-09-28 14:29:04 EDT
Why was the udev-rule changed from 10-wacom.rules in fc5 to 60-wacom.rules in
fc6tx?  And if it is as simpel to fix by renaming it, can it be fixed before fc6
final?
Comment 4 Gérard Milmeister 2006-10-28 07:00:50 EDT
I confirm that this problem is still present in FC6.
I linked 60-wacom.rules to 10-wacom.rules and it works again. This is an easy
bug to fix, I think, so the linuxwacom package should be simple to update.
Comment 5 A. Lok 2006-10-28 08:59:24 EDT
I just installed FC6 final, and can also confirm it still there. Version updated
to fc6.

version: linuxwacom-0.7.4_1-2.1
Comment 6 Gen Zhang 2006-10-29 16:58:37 EST
Changelog (rpm -q --changelog) says:

* Wed May 10 2006 Kristian Høgsberg <krh@redhat.com> 0:0.7.4_1-1
- Update to 0.7.4-1 release.
- Change udev rule to use == instead of = for matching kernel name
  (#191248).
- Drop linuxwacom-0.7.2-modular-sdk.patch and pass --with-xorg-sdk=/usr.
- Change udev rule to be 60-wacom.rules instead of 10-wacom.rules.
- Update linuxwacom-fsp.patch to patch Makefile.in instead so we avoid
  rerunning auto*.
Comment 7 A. Lok 2006-12-03 16:31:08 EST
Or maybe we could use the work-around found on the frontpage of linuxwacom.sf.net?:

"Good news: As of Nov. 15, 2006, both FC5 (kernel 2.6.18-1.2239.fc5) and FC6
(kernel 2.6.18-1.2849.fc6) work.
Bad news: link Wacom device to /dev/input/wacom for kernel 2.6.18-1.2849.fc6 is
broken. Work around: Remove NAME="input/%k", from the contents of
/etc/udev/rules.d/60-wacom.rules. (Thanks go to Johannes Fabian for reporting
the solution)."
Comment 8 A. Lok 2007-02-22 13:16:11 EST
Problem still present in Fedora 7 test1
Comment 9 Bill Nottingham 2007-03-02 12:29:09 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.
Comment 10 Mikko Huhtala 2007-05-22 03:04:50 EDT
I got my tablet (Graphire 4) to work on Fedora 7 by changing 60-wacom.rules from

  KERNEL=="event*",SYSFS{idVendor}=="056a",NAME="input/%k",SYMLINK="input/wacom%e"

to

  KERNEL=="event*", SYSFS{idVendor}=="056a", SYMLINK="input/wacom"

I did not change the number in the file name from 60. For some reason %e did not
get replaced by a number, so I took it out and now it works. I did have %e on
FC6 and that worked there.

I'm using

kernel-2.6.21-1.3163.fc7
udev-106-4.fc7


Comment 11 Konstantin Dmitryev 2007-06-23 02:11:01 EDT
I have same problem on fc6 with graphire2.
Problem resolved by renaming 60-wacom.rules to 10-wacom.rules. (It seems,
50-udev.rules blocks further processing of same rules.
Also I changed

KERNEL=="event*",SYSFS{idVendor}=="056a",NAME="input/%k",SYMLINK="input/wacom%e"

to

KERNEL=="event*", SYSFS{idVendor}=="056a", NAME="input/%k", SYMLINK+="input/wacom"

(added '+' after SYMLINK and removed %e cause it IS DEPRECATED according to
documentation)/
Comment 12 A. Lok 2007-06-23 06:21:28 EDT
There's a working '60-wacom.rules' in comment #5 of BZ191248. 

I hope the package could be updated to include this new rule. This bug is
sitting here for almost a year, without any action taken. While it is quite
simple to fix.
Comment 13 Christian Iseli 2007-07-05 19:00:25 EDT
*** Bug 163603 has been marked as a duplicate of this bug. ***
Comment 14 Daniel Benamy 2007-07-09 19:51:16 EDT
I'm still seeing this with a fully updated F7 system. Renaming to 40-wacom.rules
causes the device to be created.
Comment 15 Gérard Milmeister 2007-07-10 04:19:39 EDT
(In reply to comment #14)
> I'm still seeing this with a fully updated F7 system. Renaming to 40-wacom.rules
> causes the device to be created.

Confirmed.
Comment 16 Gian Paolo Mureddu 2007-07-20 15:56:08 EDT
In Fedora 7 two things need to be done, set the priority of the udev rule before
 "50" and remove the "%e" (which means then that only one wacom symlink will be
created)...
Comment 17 Gérard Milmeister 2007-07-24 05:27:25 EDT
Why is this bug not fixed? It seems to very simple.
Comment 18 Fedora Update System 2007-07-25 01:08:46 EDT
linuxwacom-0.7.6.4-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 19 A. Lok 2007-08-19 15:42:38 EDT
The new udev-rules in linuxwacom-0.7.6.4-2.fc7 and linuxwacom-0.7.6.4-4.fc8 work
for me.

Note You need to log in before you can comment on or make changes to this bug.