Bug 1969311 - python-yaql: Fix required for Python 3.10 compatibility (abc.collections)
Summary: python-yaql: Fix required for Python 3.10 compatibility (abc.collections)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-yaql
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joel Capitao
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10 1926612 1969040
TreeView+ depends on / blocked
 
Reported: 2021-06-08 07:44 UTC by Javier Peña
Modified: 2021-06-16 08:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-16 08:25:37 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Javier Peña 2021-06-08 07:44:58 UTC
Description of problem:

Any package depending on python-yaql fails on Python 3.10 because it has not switched yet to use collections.abc

Version-Release number of selected component (if applicable):

Rawhide

How reproducible:

Always

Steps to Reproduce:
1. Try to build a package depending on python-yaql, for example https://kojipkgs.fedoraproject.org//work/tasks/1999/69521999/build.log


Actual results:
Build fails

Expected results:
Build succeeds

Additional info:

There is patch [1] proposed some time ago to fix the build in python-yaql.

[1] - https://src.fedoraproject.org/rpms/python-yaql/pull-request/6#

Comment 1 Joel Capitao 2021-06-16 07:58:38 UTC
PR proposed: https://src.fedoraproject.org/rpms/python-yaql/pull-request/6

Comment 2 Alfredo Moralejo 2021-06-16 08:25:37 UTC
Fixed in python-yaql-1.1.3-18.fc35 https://koji.fedoraproject.org/koji/taskinfo?taskID=70217035


Note You need to log in before you can comment on or make changes to this bug.