Bug 1969604 - activates after unlock - fixed upstream ; update to latest version
Summary: activates after unlock - fixed upstream ; update to latest version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-no-overview
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-08 18:25 UTC by René Genz
Modified: 2021-06-24 16:51 UTC (History)
1 user (show)

Fixed In Version: gnome-shell-extension-no-overview-8-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-24 16:51:47 UTC
Type: Bug


Attachments (Terms of Use)

Description René Genz 2021-06-08 18:25:42 UTC
Description of problem:
no-overview GNOME extension falsely activates for first overview mode activation after unlock (due to suspending computer or locking screen).

Version-Release number of selected component (if applicable):
gnome-shell-extension-no-overview-4.1.fc34.noarch

How reproducible:
100%, easy

Steps to Reproduce:
1. log in to GNOME session
2. enable extension: gnome-extension enable no-overview@fthx
3. log out and in again
4. lock screen
5. unlock screen
6. activate GNOME overview mode

Actual results:
overview mode left automatically

Expected results:
stay in overview mode

Additional info:
Please, update to latest upstream version. It is fixed upstream, see commits from "Apr 19, 2021" at https://github.com/fthx/no-overview/commits/main
I verified by downloading files manually.

Comment 1 fujiwara 2021-06-15 13:56:50 UTC
Thank you for the info. I noticed the version 8 is a little different from git master but I will release version 8 for Fedora.

Comment 2 Fedora Update System 2021-06-15 13:58:15 UTC
FEDORA-2021-7d2cc0842b has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-7d2cc0842b

Comment 3 Fedora Update System 2021-06-16 02:02:30 UTC
FEDORA-2021-7d2cc0842b has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7d2cc0842b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7d2cc0842b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-06-24 16:51:47 UTC
FEDORA-2021-7d2cc0842b has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.